ar71xx: add model detection for UniFi AC-LR
authorAndreas Ziegler <dev@andreas-ziegler.de>
Tue, 22 Oct 2019 20:44:29 +0000 (22:44 +0200)
committerDavid Bauer <mail@david-bauer.net>
Wed, 23 Oct 2019 10:31:48 +0000 (12:31 +0200)
This commit adds correct model detection for UniFi
AC-LR. Previously, said device was incorrectly detected
as UniFi-AC-LITE/MESH.

The Information about the device is stored at 0xC in the EEPROM
partition. It corresponds to the sysid in /etc/board.info of the
Ubiquiti stock firmware.

Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de>
[adjust naming style of target to existing ones]
Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/image/generic-ubnt.mk

index 03dfbcebf9bff048d9d5149a323257ea26f2e724..044ef4eae5e1cd2f04bacc5b0c18a151f2fe1253 100755 (executable)
@@ -111,6 +111,9 @@ ubnt_unifi_ac_board_detect() {
        "e517")
                model="Ubiquiti UniFi-AC-LITE"
                ;;
+       "e527")
+               model="Ubiquiti UniFi-AC-LR"
+               ;;
        "e537")
                model="Ubiquiti UniFi-AC-PRO"
                ;;
index 5a4517f81f86b9f7bb067bcc5ce891f6d809c5d4..b82ac8686f6b2b0eeabb2ec675efcaef2c152fe2 100644 (file)
@@ -138,6 +138,12 @@ define Device/ubnt-unifiac-lite
 endef
 TARGET_DEVICES += ubnt-unifiac-lite
 
+define Device/ubnt-unifiac-lr
+  $(Device/ubnt-unifiac-lite)
+  DEVICE_TITLE := Ubiquiti UniFi AC-LR
+endef
+TARGET_DEVICES += ubnt-unifiac-lr
+
 define Device/ubnt-unifiac-mesh
   $(Device/ubnt-unifiac-lite)
   DEVICE_TITLE := Ubiquiti UniFi AC-Mesh