uboot-zynq: copy U-Boot images to STAGING_DIR
authorLuis Araneda <luaraneda@gmail.com>
Tue, 4 Sep 2018 01:39:58 +0000 (22:39 -0300)
committerJohn Crispin <john@phrozen.org>
Mon, 10 Sep 2018 06:54:25 +0000 (08:54 +0200)
Create a directory inside STAGING_DIR and copy U-Boot
output images, so they can be used later when creating the
sdcard image

Additionally, like others targets, override the default
install method to avoid copying the images to bin directory

Signed-off-by: Luis Araneda <luaraneda@gmail.com>
package/boot/uboot-zynq/Makefile

index c4779249c4a1b4470f8b7425c087615ea230bd0d..31575d7cae3d8128450992846a0955b70618e762 100644 (file)
@@ -49,6 +49,15 @@ UBOOT_TARGETS := \
        zybo \
        zybo_z7
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(CP) $(PKG_BUILD_DIR)/spl/boot.bin $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-boot.bin
+       $(CP) $(PKG_BUILD_DIR)/u-boot.img $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-u-boot.img
+endef
+
+define Package/u-boot/install/default
+endef
+
 Build/Exports:=$(Host/Exports)
 
 $(eval $(call BuildPackage/U-Boot))