bcm4908: prepare for Asus GT-AX6000 support
authorRafał Miłecki <rafal@milecki.pl>
Wed, 20 Jul 2022 18:03:56 +0000 (20:03 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 1 Sep 2022 10:46:37 +0000 (12:46 +0200)
It isn't tested & Linux DT will surely need more work.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 3f2b2fe084c0019221a17e3217a01c41d003f6fd)

target/linux/bcm4908/image/Makefile

index 385556fc000a513e06bd62c82ff7e03ecff3ec7b..7116c2a9f1fb2355dd29707d251be9c85a4ee124 100644 (file)
@@ -87,6 +87,16 @@ define Device/asus_gt-ac5300
 endef
 TARGET_DEVICES += asus_gt-ac5300
 
+define Device/asus_gt-ax6000
+  DEVICE_VENDOR := Asus
+  DEVICE_MODEL := GT-AX6000
+  DEVICE_DTS := broadcom/bcmbca/bcm4912-asus-gt-ax6000
+  IMAGES := pkgtb
+  IMAGE/pkgtb := append-rootfs | pkgtb
+  SOC := bcm4912
+endef
+# TARGET_DEVICES += asus_gt-ax6000
+
 define Device/netgear_r8000p
   DEVICE_VENDOR := Netgear
   DEVICE_MODEL := R8000P