include/version.mk: rework repository url handling
authorJo-Philipp Wich <jo@mein.io>
Tue, 12 Apr 2016 22:31:15 +0000 (00:31 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 12 Apr 2016 22:31:15 +0000 (00:31 +0200)
- Add %A placeholder for substituting the package architecture
- Change %U placeholder to refer to the toplevel repository URL
- Construct package feed URLs relative to the toplevel one to match new layout

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/feeds.mk
include/version.mk
package/base-files/image-config.in

index ef7a09f4cd272ded4da736a37c516b77d8e1ada2..a5ce877967f450b13a155d4d9bac059981d2f2b2 100644 (file)
@@ -43,12 +43,10 @@ endef
 # 1: destination file
 define FeedSourcesAppend
 ( \
+  echo "src/gz %n_core %U/targets/%S/packages"; \
   $(strip $(if $(CONFIG_PER_FEED_REPO), \
-       $(foreach feed,base kernel $(FEEDS_ENABLED),echo "src/gz %n_$(feed) %U/$(feed)";) \
+       $(foreach feed,base $(FEEDS_ENABLED),echo "src/gz %n_$(feed) %U/packages/%A/$(feed)";) \
        $(if $(CONFIG_PER_FEED_REPO_ADD_DISABLED), \
-               $(foreach feed,$(FEEDS_DISABLED),echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$(feed) %U/$(feed)";)) \
-  , \
-       echo "src/gz %n %U"; \
-  )) \
+               $(foreach feed,$(FEEDS_DISABLED),echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$(feed) %U/packages/%A/$(feed)";)))) \
 ) >> $(1)
 endef
index d8da358d696912bad879d48edf9b57d652fe4c91..15a566b508a5ba219820f36a3cb91521279271c0 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE Project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -31,7 +32,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots/trunk/%S/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),LEDE)
@@ -84,6 +85,7 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
        -e 's,%R,$(REVISION),g' \
        -e 's,%T,$(BOARD),g' \
        -e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
+       -e 's,%A,$(ARCH_PACKAGES),g' \
        -e 's,%t,$(VERSION_TAINTS),g' \
        -e 's,%M,$(VERSION_MANUFACTURER),g' \
        -e 's,%m,$(VERSION_MANUFACTURER_URL),g' \
index 5f84d115e53f7a02f8944e0fb19b5eba7b2157b6..c68f0b4a37d924d7a670b3989e4e5222ca72d3db 100644 (file)
@@ -170,7 +170,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.lede-project.org/snapshots/trunk/%S/packages"
+               default "http://downloads.lede-project.org/snapshots"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
@@ -185,6 +185,7 @@ if VERSIONOPT
                         %d .. Distribution name or "lede", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
+                        %A .. Package architecture
                         %t .. Build taint flags, e.g. "no-all busybox"
                         %M .. Manufacturer name or "Lede"
                         %P .. Product name or "Generic"