prefer the cs5535 gpiolib driver after 2.6.32
authorFlorian Fainelli <florian@openwrt.org>
Sat, 30 Oct 2010 22:35:54 +0000 (22:35 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 30 Oct 2010 22:35:54 +0000 (22:35 +0000)
SVN-Revision: 23728

package/kernel/modules/other.mk

index b5b659a967d846b04368b83477482e996b478000..623f5078e8ba59c9551c9b41ca9fbd9d03c725f3 100644 (file)
@@ -167,9 +167,15 @@ define KernelPackage/gpio-cs5535
   SUBMENU:=$(OTHER_MENU)
   TITLE:=AMD CS5535/CS5536 GPIO driver
   DEPENDS:=@TARGET_x86
   SUBMENU:=$(OTHER_MENU)
   TITLE:=AMD CS5535/CS5536 GPIO driver
   DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_CS5535_GPIO
+  KCONFIG:=CONFIG_CS5535_GPIO \
+          CONFIG_GPIO_CS5535
+ifeq ($(CONFIG_LINUX_2_6_32),y)
   FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
   AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
   FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
   AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
+else
+  FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
+endif
 endef
 
 define KernelPackage/gpio-cs5535/description
 endef
 
 define KernelPackage/gpio-cs5535/description