imx6: build support for the ventana ethernet expansion board into the kernel instead...
authorFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 08:59:10 +0000 (09:59 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 11:10:20 +0000 (12:10 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/netdevices.mk
target/linux/imx6/config-4.4
target/linux/imx6/image/Makefile

index 8be64530906d5c04523bb41e9adc790fe39db9c6..18370ddcc8ebd389f596c63c5e9d093e8ecd1b7c 100644 (file)
@@ -130,24 +130,6 @@ endef
 $(eval $(call KernelPackage,et131x))
 
 
-define KernelPackage/gw16083
-  SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=Gateworks Ventana Ethernet Expansion Mezzanine driver
-  URL:=http://www.gateworks.com
-  FILES:=$(LINUX_DIR)/drivers/net/phy/gw16083.ko
-  KCONFIG:=CONFIG_GATEWORKS_GW16083
-  DEPENDS:=@TARGET_imx6 @PCI_SUPPORT +kmod-libphy +kmod-igb
-  AUTOLOAD:=$(call AutoLoad,36,gw16083)
-endef
-
-define KernelPackage/gw16083/description
- This package contains the gw16083 kernel module for supporting the Gateworks
- Ventana Ethernet Expansion Mezzanine.
-endef
-
-$(eval $(call KernelPackage,gw16083))
-
-
 define KernelPackage/phylib-broadcom
    SUBMENU:=$(NETWORK_DEVICES_MENU)
    TITLE:=Broadcom Ethernet PHY library
index 44c0e99f3aa2ebaf9e3771e8a6c97ea11ff621b2..353ca2e6d875637e2d43e50974d3af2092f27045 100644 (file)
@@ -144,6 +144,7 @@ CONFIG_FS_MBCACHE=y
 CONFIG_FS_POSIX_ACL=y
 CONFIG_FTRACE=y
 # CONFIG_FTRACE_SYSCALLS is not set
+CONFIG_GATEWORKS_GW16083=y
 CONFIG_GENERIC_ALLOCATOR=y
 CONFIG_GENERIC_BUG=y
 CONFIG_GENERIC_CLOCKEVENTS=y
index 2c170582506fd7af33c635794c82e768c49fd46b..2e4763ea651c24ce64718c17b03b0482977a5bca 100644 (file)
@@ -90,7 +90,7 @@ define Device/ventana
        kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
        kmod-can kmod-can-flexcan kmod-can-raw \
        kmod-hwmon-gsc \
-       kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
+       kmod-leds-gpio kmod-pps-gpio \
        kobs-ng
   KERNEL += | boot-overlay
   IMAGES := nand.ubi bootfs.tar.gz