brcm63xx: fixup broken patch after kernel bump
authorJonas Gorski <jonas.gorski@gmail.com>
Tue, 14 May 2019 11:13:53 +0000 (13:13 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Tue, 14 May 2019 11:15:11 +0000 (13:15 +0200)
Fixes the following compilation issue that was introduced with the bump
to 4.14.118:

  CC      drivers/gpio/gpiolib-of.o
drivers/gpio/gpiolib-of.c: In function 'of_gpiochip_add':
drivers/gpio/gpiolib-of.c:510:12: error: too few arguments to function 'of_gpiochip_scan_gpios'
   status = of_gpiochip_scan_gpios(chip);
            ^~~~~~~~~~~~~~~~~~~~~~
drivers/gpio/gpiolib-of.c:247:5: note: declared here
 int of_gpiochip_scan_gpios(struct gpio_chip *chip, unsigned int start,
     ^~~~~~~~~~~~~~~~~~~~~~
scripts/Makefile.build:326: recipe for target 'drivers/gpio/gpiolib-of.o' failed

Fixes: 09050b6fe228 ("kernel: bump 4.14 to 4.14.118")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch

index 61e1b282c7371227d8675b3ecd85a0c845d2629a..a42c894549aff195e9e2a164f3aac0afd69045a3 100644 (file)
@@ -77,7 +77,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
 -              of_node_put(chip->of_node);
 -              gpiochip_remove_pin_ranges(chip);
 +      if (!chip->request) {
-+              status = of_gpiochip_scan_gpios(chip);
++              status = of_gpiochip_scan_gpios(chip, 0, chip->ngpio);
 +              if (status) {
 +                      of_node_put(chip->of_node);
 +                      gpiochip_remove_pin_ranges(chip);