dnsmasq: restore ability to include/exclude raw device names
authorJo-Philipp Wich <jo@mein.io>
Mon, 10 Jul 2017 08:53:29 +0000 (10:53 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 25 Oct 2017 07:57:58 +0000 (09:57 +0200)
Commit 5cd88f4 "dnsmasq: remove use of uci state for getting network ifname"
broke the ability to specify unmanaged network device names for inclusion
and exclusion in the uci configuration.

Restore support for raw device names by falling back to the input value
when "network_get_device" yields no result.

Fixes FS#876.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit a89c36b50875e61c790113d3adee10621575788a)

package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dnsmasq.init

index 94fd70232c7a27bb448d9b91507fa1446d0d838d..8eed5427a40d8131bed710d68eedcb80a3839930 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.78
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
index a762cd3309a5a951e0947541d8e2ada587d209d2..1ecbb3c689365b33c71c8110fb512a43e3febdb6 100644 (file)
@@ -116,12 +116,12 @@ append_ipset() {
 }
 
 append_interface() {
-       network_get_device ifname "$1" || return
+       network_get_device ifname "$1" || ifname="$1"
        xappend "--interface=$ifname"
 }
 
 append_notinterface() {
-       network_get_device ifname "$1" || return
+       network_get_device ifname "$1" || ifname="$1"
        xappend "--except-interface=$ifname"
 }