ath79: add support for Netgear WNDR4300 v2
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Sun, 22 Dec 2019 20:54:33 +0000 (21:54 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 19:55:56 +0000 (20:55 +0100)
This patch introduces support for Netgear WNDR4300v2.

Specification
=============
  * Description: Netgear WNDR4300 v2
  * Loader: U-boot
  * SOC: Qualcomm Atheros QCA9563 (775 MHz)
  * RAM: 128 MiB
  * Flash: 2 MiB SPI-NOR + 128 MiB SPI-NAND
- NOR: U-boot binary: 256 KiB
- NOR: U-boot environment: 64 KiB
- NOR: ART Backup: 64 KiB
  - NOR: Config: 64 KiB
- NOR: Traffic Meter: 64 KiB
- NOR: POT: 64 KiB
- NOR: Reserved: 1408 KiB
- NOR: ART: 64 KiB
- NAND: Firmware: 25600 KiB (see notes for OpenWrt)
- NAND: Language: 2048 KiB
- NAND: mtdoops Crash Dump: 128 KiB
- NAND: Reserved: 103296 KiB
  * Ethernet: 5 x 10/100/1000 (4 x LAN, 1 x WAN) (AR8337)
  * Wireless:
- 2.4 GHz b/g/n (internal)
- 5 GHz a/n (AR9580)
  * USB: yes, 1 x USB 2.0
  * Buttons:
- Reset
- WiFi (rfkill)
- WPS
  * LEDs:
- Power (amber/green)
- WAN (amber/green)
- WLAN 2G (green)
- WLAN 5G (blue)
- 4 x LAN (amber/green)
- USB (green)
- WPS (green)
  * UART: 4-pin connector JP1, 3.3V (Vcc, TX, RX, GND), 115200 8N1
  * Power supply: DC 12V 1.5A
  * MAC addresses: LAN=WLAN2G on case label, WAN +1, WLAN5G +2

Important Notes
===============
0. NOR Flash (2 MiB) is not touched by OpenWrt installation.
1. NAND Flash (128 MiB) layout under OpenWrt is changed as follows:
   all space is split between 4 MiB kernel and 124 MiB UBI areas;
   vendor partitions (language and mtdoops) are removed; kernel space
   size can be further expanded if needed; maximum image size is set
   to 25600k for compatibility reasons and can also be increased.
2. CPU clock is 775 MHz, not 750 MHz.
3. 5 GHz wireless radio chip is Atheros AR9580-AR1A with bogus PCI
   device ID 0xabcd. For ath9k driver to load successfully, this is
   overriden in DTS with correct value for this chip, 0x0033.
4. RFKILL button is wired to AR9580 pin 9 which is normally disabled
   by chip definition in ath9k code (0x0000F4FF gpio mask). Therefore
   'qca,gpio-mask=<0xf6ff>' hack must be used for button to work
   properly.
5. USB port is always on, no GPIO for 5V power control has been
   identified.

Installation
============
  * TFTP recovery
  * TFTP via U-boot prompt
  * sysupgrade
  * Web interface

Test build configuration
========================
CONFIG_TARGET_ath79=y
CONFIG_TARGET_ath79_nand=y
CONFIG_TARGET_ath79_nand_DEVICE_netgear_wndr4300-v2=y
CONFIG_ALL_KMODS=y
CONFIG_DEVEL=y
CONFIG_CCACHE=y
CONFIG_COLLECT_KERNEL_DEBUG=y
CONFIG_IMAGEOPT=y

Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9563_netgear_wndr.dtsi [new file with mode: 0644]
target/linux/ath79/dts/qca9563_netgear_wndr4300-v2.dts [new file with mode: 0644]
target/linux/ath79/image/nand.mk
target/linux/ath79/nand/base-files/etc/board.d/01_leds
target/linux/ath79/nand/base-files/etc/board.d/02_network
target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom

index f956cf4ed40a9814af4f7ff333cc75daed9b4d37..85a0342a605e2a32b310ff75a3128c168c8ceffd 100644 (file)
@@ -26,6 +26,7 @@ glinet,gl-ar750s-nor-nand|\
 librerouter,librerouter-v1|\
 netgear,ex6400|\
 netgear,ex7300|\
+netgear,wndr4300-v2|\
 netgear,wnr1000-v2|\
 netgear,wnr2000-v3|\
 netgear,wnr2200-8m|\
diff --git a/target/linux/ath79/dts/qca9563_netgear_wndr.dtsi b/target/linux/ath79/dts/qca9563_netgear_wndr.dtsi
new file mode 100644 (file)
index 0000000..2ab9b0b
--- /dev/null
@@ -0,0 +1,256 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &led_power_amber;
+               led-failsafe = &led_power_amber;
+               led-running = &led_power_green;
+               led-upgrade = &led_power_amber;
+               label-mac-device = &eth0;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       ath9k-keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               rfkill {
+                       label = "rfkill";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&ath9k 9 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds: leds {
+               compatible = "gpio-leds";
+
+               pinctrl-names = "default";
+               pinctrl-0 = <&jtag_disable_pins>;
+
+               led_power_green: power_green {
+                       label = "netgear:green:power";
+                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power_amber: power_amber {
+                       label = "netgear:amber:power";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "keep";
+               };
+
+               wan_green {
+                       label = "netgear:green:wan";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_amber {
+                       label = "netgear:amber:wan";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g_green {
+                       label = "netgear:green:wlan2g";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wps_green {
+                       label = "netgear:green:wps";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       ath9k-leds {
+               compatible = "gpio-leds";
+
+               wlan5g_blue {
+                       label = "netgear:blue:wlan5g";
+                       gpios = <&ath9k 7 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <2>;
+       cs-gpios = <0>, <0>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x40000 0x10000>;
+                       };
+
+                       partition@50000 {
+                               label = "caldata_backup";
+                               reg = <0x50000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "config";
+                               reg = <0x60000 0x10000>;
+                       };
+
+                       partition@70000 {
+                               label = "traffic_meter";
+                               reg = <0x70000 0x10000>;
+                       };
+
+                       partition@80000 {
+                               label = "pot";
+                               reg = <0x80000 0x10000>;
+                       };
+
+                       partition@90000 {
+                               label = "reserved";
+                               reg = <0x90000 0x160000>;
+                       };
+
+                       art: partition@1f0000 {
+                               label = "caldata";
+                               reg = <0x1f0000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+
+       flash@1 {
+               compatible = "spi-nand";
+               reg = <1>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "kernel";
+                               reg = <0x0 0x400000>;
+                       };
+
+                       partition@400000 {
+                               label = "ubi";
+                               reg = <0x400000 0x7c00000>;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+               qca,mib-poll-interval = <500>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x00000080 /* PORT0 PAD MODE CTRL */
+                       0x10 0x81000080 /* POWER_ON_STRIP */
+                       0x50 0xcc35cc35 /* LED_CTRL0 */
+                       0x54 0xcb37cb37 /* LED_CTRL1 */
+                       0x58 0x00000000 /* LED_CTRL2 */
+                       0x5c 0x00f3cf00 /* LED_CTRL3 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+                       0x94 0x00000200 /* PORT6_STATUS */
+                       >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0x03000101 0x00000101 0x00001919>;
+
+       mtd-mac-address = <&art 0x0>;
+
+       phy-mode = "sgmii";
+       phy-handle = <&phy0>;
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+       qca,no-eeprom;
+};
+
+&pcie {
+       status = "okay";
+
+       ath9k: wifi@0,0 {
+               /* chip is AR9580, override bogus PCI ID 168c:abcd */
+               compatible = "pci168c,0033";
+               reg = <0x0000 0 0 0 0>;
+               mtd-mac-address = <&art 0xc>;
+               qca,no-eeprom;
+               qca,gpio-mask=<0xf6ff>; /* unmask pin 9 for RFKILL button */
+               #gpio-cells = <2>;
+               gpio-controller;
+       };
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&usb0 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&uart {
+       status = "okay";
+};
diff --git a/target/linux/ath79/dts/qca9563_netgear_wndr4300-v2.dts b/target/linux/ath79/dts/qca9563_netgear_wndr4300-v2.dts
new file mode 100644 (file)
index 0000000..e4b4ba2
--- /dev/null
@@ -0,0 +1,19 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+
+#include "qca9563_netgear_wndr.dtsi"
+
+/ {
+       compatible = "netgear,wndr4300-v2", "qca,qca9563";
+       model = "Netgear WNDR4300 v2";
+};
+
+&leds {
+       usb_green {
+               label = "netgear:green:usb";
+               gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+               trigger-sources = <&hub_port0>;
+               linux,default-trigger = "usbport";
+       };
+};
index d2018afb616133851082d7d9289d0ecf243b06f0..d5213523e425ed159c98c2cccba5ebe3d69b2405 100644 (file)
@@ -154,6 +154,17 @@ define Device/netgear_wndr4300
 endef
 TARGET_DEVICES += netgear_wndr4300
 
+define Device/netgear_wndr4300-v2
+  SOC := qca9563
+  DEVICE_MODEL := WNDR4300
+  DEVICE_VARIANT := v2
+  NETGEAR_KERNEL_MAGIC := 0x27051956
+  NETGEAR_BOARD_ID := WNDR4500series
+  NETGEAR_HW_ID := 29764821+2+128+128+3x3+3x3+5508012175
+  $(Device/netgear_ath79_nand)
+endef
+TARGET_DEVICES += netgear_wndr4300-v2
+
 define Device/zyxel_nbg6716
   SOC := qca9558
   DEVICE_VENDOR := ZyXEL
index 49d4005495c5650aaee2e0d7c62330fa63a0c15e..0376b7cfc662373827e144462b172dda61c869c9 100755 (executable)
@@ -13,7 +13,8 @@ glinet,gl-ar300m-nor)
        ucidef_set_led_netdev "lan" "LAN" "gl-ar300m:green:lan" "eth0"
        ;;
 netgear,wndr3700-v4|\
-netgear,wndr4300)
+netgear,wndr4300|\
+netgear,wndr4300-v2)
        ucidef_set_led_switch "wan-amber" "WAN (amber)" "netgear:amber:wan" "switch0" "0x20"
        ;;
 esac
index f7e43addc1abd0434c2068e96fd1a0b95b540ee8..135a06d44bf4428d80c38b4e536e43583b6b1e41 100755 (executable)
@@ -17,7 +17,8 @@ ath79_setup_interfaces()
                        "0@eth0" "2:lan:2" "3:lan:1" "1:wan"
                ;;
        netgear,wndr3700-v4|\
-       netgear,wndr4300)
+       netgear,wndr4300|\
+       netgear,wndr4300-v2)
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan"
                ;;
@@ -37,7 +38,8 @@ ath79_setup_macs()
 
        case "$board" in
        netgear,wndr3700-v4|\
-       netgear,wndr4300)
+       netgear,wndr4300|\
+       netgear,wndr4300-v2)
                wan_mac=$(mtd_get_mac_binary caldata 0x6)
                ;;
        zyxel,nbg6716)
index 25bafe67ac5fa7c8a4f2bb1266a61f4577be9f32..7ee291d1096512e404debbe1e5e58e696bd59d87 100644 (file)
@@ -10,7 +10,8 @@ case "$FIRMWARE" in
 "ath9k-eeprom-ahb-18100000.wmac.bin")
        case $board in
        netgear,wndr3700-v4|\
-       netgear,wndr4300)
+       netgear,wndr4300|\
+       netgear,wndr4300-v2)
                caldata_extract "caldata" 0x1000 0x440
                ;;
        zyxel,nbg6716)
@@ -25,7 +26,8 @@ case "$FIRMWARE" in
 "ath9k-eeprom-pci-0000:00:00.0.bin")
        case $board in
        netgear,wndr3700-v4|\
-       netgear,wndr4300)
+       netgear,wndr4300|\
+       netgear,wndr4300-v2)
                caldata_extract "caldata" 0x5000 0x440
                ;;
        *)