linux: kmod-e100: use preconverted firmware files
authorJo-Philipp Wich <jo@mein.io>
Thu, 21 Apr 2016 14:39:59 +0000 (16:39 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 21 Apr 2016 14:39:59 +0000 (16:39 +0200)
Instead of converting the firmware files ourselves, use the files
generated during the normal kernel build process. This fixes packaging
kmod-e100 in the SDK environment.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/netdevices.mk

index 417a6a6114b563bcfa60fc3238afd85dff7fa171..eaa37d1a7d1a61919114ad5aa627f815ef90f513 100644 (file)
@@ -464,9 +464,9 @@ endef
 
 define KernelPackage/e100/install
        $(INSTALL_DIR) $(1)/lib/firmware/e100
-       $(foreach file,d101m_ucode.bin d101s_ucode.bin d102e_ucode.bin, \
-               $(TARGET_CROSS)objcopy -Iihex -Obinary $(LINUX_DIR)/firmware/e100/$(file).ihex $(1)/lib/firmware/e100/$(file); \
-       )
+       $(INSTALL_DATA) $(LINUX_DIR)/firmware/e100/d101m_ucode.bin $(1)/lib/firmware/e100/
+       $(INSTALL_DATA) $(LINUX_DIR)/firmware/e100/d101s_ucode.bin $(1)/lib/firmware/e100/
+       $(INSTALL_DATA) $(LINUX_DIR)/firmware/e100/d102e_ucode.bin $(1)/lib/firmware/e100/
 endef
 
 $(eval $(call KernelPackage,e100))