sunxi: add a kmod package for sun4i_spdif
authorAndre Heider <a.heider@gmail.com>
Tue, 8 Oct 2019 13:42:18 +0000 (15:42 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 15:45:02 +0000 (17:45 +0200)
Tested on a A20 board:
$ cat /proc/asound/cards
 0 [SPDIF          ]: On-board_SPDIF - On-board SPDIF
                      On-board SPDIF

Size of the module for a 32bit kernel:
60708 linux-5.4.66/sound/soc/sunxi/sun4i-spdif.ko

Signed-off-by: Andre Heider <a.heider@gmail.com>
target/linux/sunxi/modules.mk

index b8ea7d5cb66832d873024af7a5f66f2446681f06..6d2de98658271a7345c262ceabfa9da643ef40a6 100644 (file)
@@ -68,7 +68,6 @@ endef
 
 $(eval $(call KernelPackage,sun4i-emac))
 
-
 define KernelPackage/sound-soc-sunxi
   TITLE:=AllWinner built-in SoC sound support
   KCONFIG:=CONFIG_SND_SUN4I_CODEC
@@ -83,3 +82,18 @@ define KernelPackage/sound-soc-sunxi/description
 endef
 
 $(eval $(call KernelPackage,sound-soc-sunxi))
+
+define KernelPackage/sound-soc-sunxi-spdif
+  TITLE:=Allwinner A10 SPDIF Support
+  KCONFIG:=CONFIG_SND_SUN4I_SPDIF
+  FILES:=$(LINUX_DIR)/sound/soc/sunxi/sun4i-spdif.ko
+  AUTOLOAD:=$(call AutoLoad,65,sun4i-spdif)
+  DEPENDS:=@TARGET_sunxi +kmod-sound-soc-spdif
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-sunxi-spdif/description
+  Kernel support for Allwinner A10 SPDIF Support
+endef
+
+$(eval $(call KernelPackage,sound-soc-sunxi-spdif))