build: add apend-uboot command
authorDavid Bauer <mail@david-bauer.net>
Tue, 15 May 2018 17:02:48 +0000 (19:02 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 May 2018 18:34:14 +0000 (20:34 +0200)
This commit adds an append-uboot command to append U-Boot from the
bin-directory.

Signed-off-by: David Bauer <mail@david-bauer.net>
include/image-commands.mk

index e0322080e96c0b115fbd2c861e18c180afe12155..395e31f9947cc9e81bd2e01361162ca0c7bb794c 100644 (file)
@@ -186,6 +186,10 @@ define Build/append-ubi
        rm $@.tmp
 endef
 
+define Build/append-uboot
+       dd if=$(UBOOT_PATH) >> $@
+endef
+
 define Build/pad-to
        dd if=$@ of=$@.new bs=$(1) conv=sync
        mv $@.new $@