kernel: bump 5.10 to 5.10.55
authorRui Salvaterra <rsalvaterra@gmail.com>
Mon, 2 Aug 2021 11:20:46 +0000 (12:20 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Aug 2021 15:57:34 +0000 (17:57 +0200)
No deleted or manually refreshed patches.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-version.mk
target/linux/bcm53xx/patches-5.10/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/bcm53xx/patches-5.10/310-ARM-BCM5301X-Add-DT-for-Netgear-R7900.patch
target/linux/bcm53xx/patches-5.10/500-UBI-Detect-EOF-mark-and-erase-all-remaining-blocks.patch
target/linux/bcm53xx/patches-5.10/905-BCM53573-minor-hacks.patch
target/linux/lantiq/patches-5.10/0001-MIPS-lantiq-add-pcie-driver.patch

index 1d00565c8fbbadb30898b6f871a18bf1af0d6d1f..dd55d6935928dd3cd7614a1f47acaa6436938bc8 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .137
-LINUX_VERSION-5.10 = .54
+LINUX_VERSION-5.10 = .55
 
 LINUX_KERNEL_HASH-5.4.137 = f09e5e366ce5d8bde887cda229ef17138fd1653706a702221f934f99aaa31f7c
-LINUX_KERNEL_HASH-5.10.54 = bf50c63261847187eca4a1793e5df5c1355b21697409589f6ca03e32b629be44
+LINUX_KERNEL_HASH-5.10.55 = 7581113dad67a095bc5cc32b457e1a9283f91579e248f3b547a7302157fe8889
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index c64c94ed52e4f78a6b3c8db71da257da25526050..cae6069dfc503c287546b4c1968fe6991173e9e2 100644 (file)
@@ -127,7 +127,7 @@ it on BCM4708 family.
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1880,6 +1880,7 @@ struct xhci_hcd {
+@@ -1881,6 +1881,7 @@ struct xhci_hcd {
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  #define XHCI_SG_TRB_CACHE_SIZE_QUIRK  BIT_ULL(39)
  #define XHCI_NO_SOFT_RETRY    BIT_ULL(40)
index b0800e50ae5ba07ca5a75c89f5e3ba0b6d424e81..e67d36a4e2b3b24d8b45d3af8e02a3fc8ca4b180 100644 (file)
@@ -9,7 +9,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -106,6 +106,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+@@ -116,6 +116,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
        bcm4709-buffalo-wxr-1900dhp.dtb \
        bcm4709-linksys-ea9200.dtb \
        bcm4709-netgear-r7000.dtb \
index ff9d6b0005f61ec8deb5aff2f011a34df98414c4..257214fff9116a0e123d8e577bdb15c3d7076e6d 100644 (file)
@@ -49,7 +49,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
                        return UBI_IO_BAD_HDR_EBADMSG;
 --- a/drivers/mtd/ubi/ubi.h
 +++ b/drivers/mtd/ubi/ubi.h
-@@ -822,6 +822,7 @@ extern struct mutex ubi_devices_mutex;
+@@ -824,6 +824,7 @@ extern struct mutex ubi_devices_mutex;
  extern struct blocking_notifier_head ubi_notifiers;
  
  /* attach.c */
index f47ea95c955e72949f0156c69c095c7cdf76dc48..a1d27949f0489dc35327c2c0e0d6fca9e2251944 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
  #include <linux/clockchips.h>
  #include <linux/clocksource.h>
  #include <linux/interrupt.h>
-@@ -919,6 +920,16 @@ static void arch_timer_of_configure_rate
+@@ -934,6 +935,16 @@ static void arch_timer_of_configure_rate
        if (of_property_read_u32(np, "clock-frequency", &arch_timer_rate))
                arch_timer_rate = rate;
  
@@ -76,5 +76,5 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
 +      }
 +
        /* Check the timer frequency. */
-       if (arch_timer_rate == 0)
+       if (validate_timer_rate())
                pr_warn("frequency not available\n");
index 200c5629e7ddc191506b8bea5f1d41054a749da9..c3299317917ea61e84e612797479786721141755 100644 (file)
@@ -5481,7 +5481,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1416,6 +1416,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1417,6 +1417,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);