kernel: disable IGD (video DRM) support
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 17 May 2023 15:38:48 +0000 (09:38 -0600)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 21 May 2023 12:25:52 +0000 (14:25 +0200)
IGD is only useful when accelerating a VM guest that wants to direct
render to memory in the host's framebuffer, but since OpenWrt
typically runs on headless hardware, this serves no purpose.

Also build vfio with VFIO_NOIOMMU undefined (to get all of the code
enabled), but allow it to be enabled via boot-time modparams
settings (or at run-time via sysfs writes to
"/sys/module/vfio/parameters/enable_unsafe_noiommu_mode".

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
package/kernel/linux/modules/virt.mk

index 85f47aacbf94f89bf1a589b05f58127290fb0f4b..90226b480638c29a585bc21d207ca6a586398ef2 100644 (file)
@@ -82,6 +82,8 @@ define KernelPackage/vfio
        CONFIG_VFIO \
        CONFIG_VFIO_NOIOMMU=n \
        CONFIG_VFIO_MDEV=n
+  MODPARAMS.vfio:=\
+       enable_unsafe_noiommu_mode=n
   FILES:= \
        $(LINUX_DIR)/drivers/vfio/vfio.ko \
        $(LINUX_DIR)/drivers/vfio/vfio_virqfd.ko \
@@ -102,7 +104,7 @@ define KernelPackage/vfio-pci
   DEPENDS:=@TARGET_x86_64 @PCI_SUPPORT +kmod-vfio +kmod-irqbypass
   KCONFIG:= \
        CONFIG_VFIO_PCI \
-       CONFIG_VFIO_PCI_IGD=y
+       CONFIG_VFIO_PCI_IGD=n
   FILES:= \
        $(LINUX_DIR)/drivers/vfio/pci/vfio-pci-core.ko \
        $(LINUX_DIR)/drivers/vfio/pci/vfio-pci.ko