update to 2.6.37.1
authorFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:43:59 +0000 (12:43 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:43:59 +0000 (12:43 +0000)
SVN-Revision: 25577

include/kernel-version.mk
target/linux/generic/patches-2.6.37/060-block2mtd_init.patch
target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
target/linux/generic/patches-2.6.37/980-vm_exports.patch
target/linux/malta/Makefile
target/linux/omap24xx/Makefile
target/linux/orion/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/xburst/Makefile

index 3b91203a245a0c56f1708c8380fff54acccc6190..31ac5d0630a2ab22b4bba2dd69aebe9254d94cb5 100644 (file)
@@ -20,8 +20,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.36.2)
   LINUX_KERNEL_MD5SUM:=d465f8ba05bf1b7530c596f1cca658e7
 endif
-ifeq ($(LINUX_VERSION),2.6.37)
-  LINUX_KERNEL_MD5SUM:=c8ee37b4fdccdb651e0603d35350b434
+ifeq ($(LINUX_VERSION),2.6.37.1)
+  LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
 endif
 
 # disable the md5sum check for unknown kernel versions
index 2af46a96502d4a9fe20d38fc7e19af7a2c7bc607..18f0c4e5128a6babddf9678f294bde1596892369 100644 (file)
  {
 --- a/fs/partitions/check.c
 +++ b/fs/partitions/check.c
-@@ -707,6 +707,7 @@ rescan:
+@@ -715,6 +715,7 @@ rescan:
        kfree(state);
        return 0;
  }
index 45a096d873fe87d1409ae470bbac5e369868ffc6..3725b922ce3b6a8d64e0c299006bb92af1458429 100644 (file)
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1388,3 +1389,5 @@ MODULE_LICENSE("GPL");
+@@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 35b9b925fb86e539d9383d00c3864d56c895bb18..8d8638be318c807f593ae7ccc0a456a1a90b1f32 100644 (file)
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4773,6 +4773,7 @@ int can_nice(const struct task_struct *p
+@@ -4776,6 +4776,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index e74d3869175fa2361dafde7e9fe27d300028a506..32e193ecce41bf573ffeda73e19e1896a9c71518 100644 (file)
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
 
 include $(INCLUDE_DIR)/target.mk
 
index f64d67654d55d0b6b35c5fe6a918ca5681bdbd73..9abc88e4a6afe93175d1f23ea88f8e62535d5ee0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
 MAINTAINER:=Michael Buesch <mb@bu3sch.de>
 FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
 
 define Target/Description
        TI OMAP-24xx
index 2dc5d2530c56e9a42da43c9fdf3c6e2482c3d6f5..a2dd84bb0050abb350f97178a12ed9e5e6195cc3 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 4dabb4905a47a8b17ce52e54554de0c3fc215aec..00b7a331a996de508490b568c8d0f813104c7035 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
 FEATURES:=squashfs jffs2 fpu
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 22951147c795df91515a9e4165d96de67344bd65..2c039f4f23915d130092745e746c984edacc4f0d 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 8e8888e8ff366452b2ab79f444f2e865c5e8e5bc..c58242a1be9a644f6665098f7e2117985ff7741c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=2.6.37.1
 
 DEVICE_TYPE=other