ca-certificates: ca-bundle: add symlink for openssl default setting
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 5 Jul 2018 10:51:54 +0000 (18:51 +0800)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 08:43:56 +0000 (09:43 +0100)
OpenSSL defaults X509_CERT_FILE to /etc/ssl/cert.pem.  This change is
needed for wget-ssl and possibly others to work seamlessly with fresh
ca-bundle installation

Fixes openwrt/packages#6152

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
(backported from 191078e83d127f5ed9a38366d2edaac49f9333c5)

package/system/ca-certificates/Makefile

index 5ee7a3528c9e741b0637abc675b5789e7d65f212..43003cf9255b294e2a1ec134e2ac41b594878fba 100644 (file)
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ca-certificates
 PKG_VERSION:=20180409
+PKG_RELEASE:=2
 PKG_MAINTAINER:=
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
@@ -57,6 +58,7 @@ endef
 define Package/ca-bundle/install
        $(INSTALL_DIR) $(1)/etc/ssl/certs
        cat $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt >$(1)/etc/ssl/certs/ca-certificates.crt
+       $(LN) /etc/ssl/certs/ca-certificates.crt $(1)/etc/ssl/cert.pem
 endef
 $(eval $(call BuildPackage,ca-certificates))
 $(eval $(call BuildPackage,ca-bundle))