tools: build squashfs (v3) for ath79
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 13 Jun 2018 08:51:50 +0000 (10:51 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 16 Jun 2018 08:08:51 +0000 (10:08 +0200)
Certain Netgear and AVM devices use BE squashfs for the kernel image. As
squashfs4 only supports creating LE images, add squashfs (v3) into
the tools to be built for ath79.

Trying to use an LE squashfs (thus trying to use squashfs4 only for
building the image) for the kernel image results in the bootloader
barfing and stopping.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
tools/Makefile

index d2b5daf18c233c8e94657fd61922c75770a3b35b..9a354f6c706967485762082b08c62d2b2bfcf4f4 100644 (file)
@@ -30,7 +30,8 @@ tools-y += mtools dosfstools libressl
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
-tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
+tools-$(CONFIG_TARGET_ar71xx) += lzma-old
+tools-$(CONFIG_TARGET_ar71xx)$(CONFIG_TARGET_ath79) += squashfs
 tools-$(CONFIG_USES_MINOR) += kernel2minor
 tools-y += lzma squashfs4
 tools-$(BUILD_B43_TOOLS) += b43-tools