hostapd: fix OWE settings in client mode
authorJo-Philipp Wich <jo@mein.io>
Fri, 20 Sep 2019 09:40:52 +0000 (11:40 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 14 Nov 2019 19:59:58 +0000 (20:59 +0100)
This changes fixes the generation of the wpa_supplicant client configuration
in WPA3 OWE client mode. Instead of incorrectly emitting key_mgmt=NONE, use
the proper key_mgmt=OWE setting instead.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 4209b28d23b8bf28575af5e8904194f49b81532e)

package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 233ef389ae50e13d42e2ec9cfeecfb6e2ee462a5..e94d66211d9f59488b6dca205a7adf9ed3310ef8 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 78fb736dd78c769dec03a43308ca78b917be8bd5..96cfc13a7db0f333fb60cbd01b2ba8b5f810062e 100644 (file)
@@ -795,6 +795,7 @@ wpa_supplicant_add_network() {
                none) ;;
                owe)
                        hostapd_append_wpa_key_mgmt
                none) ;;
                owe)
                        hostapd_append_wpa_key_mgmt
+                       key_mgmt="$wpa_key_mgmt"
                ;;
                wep)
                        local wep_keyidx=0
                ;;
                wep)
                        local wep_keyidx=0