ipq806x: increase kernel partition size for the Netgear Nighthawk X4 R7500
authorStefan Lippers-Hollmann <s.l-h@gmx.de>
Fri, 18 May 2018 02:12:04 +0000 (04:12 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 24 May 2018 15:24:31 +0000 (17:24 +0200)
Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the
2 MB reserved for the kernel partition by the OEM firmware anymore.

This patch increases the kernel partition from 2 MB to 4 MB, at the
expense of the rootfs, for all supported kernels.

WARNING: This breaks sysupgrade! Flashing a firmware containing this
changed partitioning from an older image with 2 MB reserved for the
kernel partion requires the tftp recovery procedure, thereby losing
all settings.

This change follows the functional example of the Netgear r7800, but
has not been runtime tested on a Netgear Nighthawk X4 R7500

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
Cc: Jonas Gorski <jonas.gorski@gmail.com>
(cherry picked from commit c228bbe616a52921a9d8fc961b3efcbdd3880c25)

target/linux/ipq806x/files-4.14/arch/arm/boot/dts/qcom-ipq8064-r7500.dts
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq8064-r7500.dts
target/linux/ipq806x/image/Makefile

index 3445a79251e7d675867edc54b91d4799f548614f..84d79a07f00312a8280d88954db6a9c938fe3b26 100644 (file)
 
                                        kernel@1340000 {
                                                label = "kernel";
 
                                        kernel@1340000 {
                                                label = "kernel";
-                                               reg = <0x1340000 0x0200000>;
+                                               reg = <0x1340000 0x0400000>;
                                        };
 
                                        };
 
-                                       ubi@1540000 {
+                                       ubi@1740000 {
                                                label = "ubi";
                                                label = "ubi";
-                                               reg = <0x1540000 0x1800000>;
+                                               reg = <0x1740000 0x1600000>;
                                        };
 
                                        netgear@2d40000 {
                                        };
 
                                        netgear@2d40000 {
index 3445a79251e7d675867edc54b91d4799f548614f..84d79a07f00312a8280d88954db6a9c938fe3b26 100644 (file)
 
                                        kernel@1340000 {
                                                label = "kernel";
 
                                        kernel@1340000 {
                                                label = "kernel";
-                                               reg = <0x1340000 0x0200000>;
+                                               reg = <0x1340000 0x0400000>;
                                        };
 
                                        };
 
-                                       ubi@1540000 {
+                                       ubi@1740000 {
                                                label = "ubi";
                                                label = "ubi";
-                                               reg = <0x1540000 0x1800000>;
+                                               reg = <0x1740000 0x1600000>;
                                        };
 
                                        netgear@2d40000 {
                                        };
 
                                        netgear@2d40000 {
index 496564de389b8900289c827be75eed03cd26b6e3..5a1faa3eadbb7d92450d75b4c247bd697ed8b65a 100644 (file)
@@ -119,7 +119,7 @@ TARGET_DEVICES += netgear_d7800
 define Device/netgear_r7500
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500
 define Device/netgear_r7500
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8064-r7500
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := R7500
        NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
        BLOCKSIZE := 128k
        NETGEAR_BOARD_ID := R7500
        NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
        BLOCKSIZE := 128k