add kmod-regmap including both i2c and spi modules
authorFlorian Fainelli <florian@openwrt.org>
Tue, 24 Jul 2012 19:43:06 +0000 (19:43 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 24 Jul 2012 19:43:06 +0000 (19:43 +0000)
This is required for quite SoC sound support

SVN-Revision: 32800

package/kernel/modules/other.mk

index 773a2bc193e8174475c6673fcb8a77a8d2cad07a..68b8e3c881ba99604d762e85a210149cd37042fc 100644 (file)
@@ -904,3 +904,20 @@ define KernelPackage/acpi-button/description
 endef
 
 $(eval $(call KernelPackage,acpi-button))
+
+define KernelPackage/regmap
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Generic register map support
+  KCONFIG:=CONFIG_REGMAP=y \
+          CONFIG_REGMAP_SPI \
+          CONFIG_REGMAP_I2C
+  FILES:=$(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
+        $(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko
+  AUTOLOAD:=$(call AutoLoad,10,regmap-i2c regmap-spi)
+endef
+
+define KernelPackage/regmap/description
+  Generic register map support
+endef
+
+$(eval $(call KernelPackage,regmap))