realtek: build factory images for all DGS-1210 models
authorMarkus Stockhausen <markus.stockhausen@gmx.de>
Wed, 6 Jul 2022 11:41:51 +0000 (13:41 +0200)
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>
Sat, 9 Jul 2022 01:10:10 +0000 (22:10 -0300)
Currently we build factory images only for DGS-1210-28 model. Relax
that constraint and take care about all models. Tested on DGS-1210-20
and should work on other models too because of common flash layout.

Tested-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de>
(cherry picked from commit 2b49ec3a28ad09446f48f1f830a42bdfe3bce9be)

target/linux/realtek/image/rtl838x.mk

index fee029aa3fef31e566ae7b1c6ec76c753ac852da..d72dc2191bf6a6fd65848604671cb6d7dfed8644 100644 (file)
@@ -17,6 +17,13 @@ define Device/d-link_dgs-1210
   DEVICE_VENDOR := D-Link
   DLINK_KERNEL_PART_SIZE := 1572864
   KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
+  CAMEO_KERNEL_PART := 2
+  CAMEO_ROOTFS_PART := 3
+  CAMEO_CUSTOMER_SIGNATURE := 2
+  CAMEO_BOARD_VERSION := 32
+  IMAGES += factory_image1.bin
+  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
+       append-rootfs | pad-rootfs | pad-to 16 | check-size | dlink-headers
 endef
 
 define Device/d-link_dgs-1210-10p
@@ -35,13 +42,6 @@ TARGET_DEVICES += d-link_dgs-1210-16
 define Device/d-link_dgs-1210-28
   $(Device/d-link_dgs-1210)
   DEVICE_MODEL := DGS-1210-28
-  CAMEO_KERNEL_PART := 2
-  CAMEO_ROOTFS_PART := 3
-  CAMEO_CUSTOMER_SIGNATURE := 2
-  CAMEO_BOARD_VERSION := 32
-  IMAGES += factory_image1.bin
-  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
-        append-rootfs | pad-rootfs | pad-to 16 | check-size | dlink-headers
 endef
 TARGET_DEVICES += d-link_dgs-1210-28