switch from ext2 to ext4 (w/o) journaling
authorImre Kaloz <kaloz@openwrt.org>
Mon, 22 Nov 2010 12:12:39 +0000 (12:12 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 22 Nov 2010 12:12:39 +0000 (12:12 +0000)
SVN-Revision: 24084

30 files changed:
Config.in
include/image.mk
scripts/metadata.pl
target/Config.in
target/linux/at91/config-default
target/linux/cobalt/Makefile
target/linux/ep93xx/Makefile
target/linux/ixp4xx/harddisk/config-default
target/linux/kirkwood/config-default
target/linux/mpc52xx/Makefile
target/linux/omap24xx/config-2.6.36
target/linux/omap24xx/config-2.6.37
target/linux/omap35xx/beagleboard/profiles/beagleboard.mk
target/linux/omap35xx/config-2.6.32
target/linux/omap35xx/gumstix/config-2.6.34
target/linux/omap35xx/gumstix/config-2.6.36
target/linux/orion/harddisk/config-default
target/linux/rb532/config-2.6.32
target/linux/rb532/config-2.6.33
target/linux/rb532/config-2.6.34
target/linux/rb532/config-2.6.35
target/linux/s3c24xx/openmoko-gta02/config-2.6.30
target/linux/uml/Makefile
target/linux/x86/Makefile
target/linux/x86/config-default
target/linux/x86/image/Config.in
target/linux/x86/image/Makefile
target/linux/xburst/config-2.6.34
target/linux/xburst/config-2.6.35
target/linux/xburst/config-2.6.36

index 458a3b3bce8c954206cccef4193040b0b56e2435..5763be02b1efccbe64a21cbbbe6f7e970a1d83f2 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -1,4 +1,4 @@
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -62,12 +62,12 @@ menu "Target Images"
 
        comment "Root filesystem images"
 
 
        comment "Root filesystem images"
 
-       config TARGET_ROOTFS_EXT2FS
-               bool "ext2"
-               default y if USES_EXT2
+       config TARGET_ROOTFS_EXT4FS
+               bool "ext4"
+               default y if USES_EXT4
                depends !TARGET_ROOTFS_INITRAMFS
                help
                depends !TARGET_ROOTFS_INITRAMFS
                help
-                 Ext2 file system with some free space for uml images
+                 Ext4 file system with some free space for uml images
 
        config TARGET_ROOTFS_ISO
                bool "iso"
 
        config TARGET_ROOTFS_ISO
                bool "iso"
@@ -103,14 +103,14 @@ menu "Target Images"
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MB)"
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MB)"
-               depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS || TARGET_rb532
+               depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
                default 48
                help
                    Allows you to change the root filesystem partition size
 
        config TARGET_ROOTFS_MAXINODE
                int "Maximum number of inodes in root filesystem"
                default 48
                help
                    Allows you to change the root filesystem partition size
 
        config TARGET_ROOTFS_MAXINODE
                int "Maximum number of inodes in root filesystem"
-               depends TARGET_ROOTFS_EXT2FS
+               depends TARGET_ROOTFS_EXT4FS
                default 6000
                help
                    Allows you to change the maximum number of inodes in the root filesystem
                default 6000
                help
                    Allows you to change the maximum number of inodes in the root filesystem
index 4ec7d91bf7fe93f5f6307a0951e82984d1ee9055..d7d981ba1cd2303dae0f28d96130e397e7156d47 100644 (file)
@@ -128,12 +128,17 @@ ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
   endef
 endif
 
   endef
 endif
 
-ifneq ($(CONFIG_TARGET_ROOTFS_EXT2FS),)
+ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024)))
 
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024)))
 
-  define Image/mkfs/ext2
-               $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
-               $(call Image/Build,ext2)
+  define Image/mkfs/ext4
+# generate an ext2 fs
+       $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4
+# convert it to ext4
+       $(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
+# fix it up
+       $(STAGING_DIR_HOST)/bin/e2fsck -fy $(KDIR)/root.ext4
+       $(call Image/Build,ext4)
   endef
 endif
 
   endef
 endif
 
@@ -184,7 +189,7 @@ define BuildImage
                $(call Image/BuildKernel)
                $(call Image/mkfs/cpiogz)
                $(call Image/mkfs/targz)
                $(call Image/BuildKernel)
                $(call Image/mkfs/cpiogz)
                $(call Image/mkfs/targz)
-               $(call Image/mkfs/ext2)
+               $(call Image/mkfs/ext4)
                $(call Image/mkfs/iso)
                $(call Image/mkfs/jffs2)
                $(call Image/mkfs/squashfs)
                $(call Image/mkfs/iso)
                $(call Image/mkfs/jffs2)
                $(call Image/mkfs/squashfs)
@@ -195,7 +200,7 @@ define BuildImage
                $(call Image/BuildKernel)
                $(call Image/mkfs/cpiogz)
                $(call Image/mkfs/targz)
                $(call Image/BuildKernel)
                $(call Image/mkfs/cpiogz)
                $(call Image/mkfs/targz)
-               $(call Image/mkfs/ext2)
+               $(call Image/mkfs/ext4)
                $(call Image/mkfs/iso)
                $(call Image/mkfs/jffs2)
                $(call Image/mkfs/squashfs)
                $(call Image/mkfs/iso)
                $(call Image/mkfs/jffs2)
                $(call Image/mkfs/squashfs)
index e86178d423c9f14d1d6ae2c5b4008bac72f19a4b..37c0a51ee796ee8989749442e6e4870f3f48e14f 100755 (executable)
@@ -163,7 +163,7 @@ sub target_config_features(@) {
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
-               /ext2/ and $ret .= "\tselect USES_EXT2\n";
+               /ext4/ and $ret .= "\tselect USES_EXT4\n";
                /targz/ and $ret .= "\tselect USES_TARGZ\n";
                /cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n";
                /ubifs/ and $ret .= "\tselect USES_UBIFS\n";
                /targz/ and $ret .= "\tselect USES_TARGZ\n";
                /cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n";
                /ubifs/ and $ret .= "\tselect USES_UBIFS\n";
index 4c65eae867305171e6a8c900952092e6192ae4c8..226624564a284cccc48506d9fb32db93021c5fa8 100644 (file)
@@ -40,7 +40,7 @@ config USES_SQUASHFS
 config USES_JFFS2
        bool
 
 config USES_JFFS2
        bool
 
-config USES_EXT2
+config USES_EXT4
        bool
 
 config USES_TARGZ
        bool
 
 config USES_TARGZ
index 9da6aace08b677dfc3ce3de4ba13ff57e16cff43..b29bb24c825a73e8e80bfb40c700eaf1e744ca6d 100644 (file)
@@ -64,7 +64,7 @@ CONFIG_DEBUG_BUGVERBOSE=y
 CONFIG_DECOMPRESS_LZMA=y
 CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
 # CONFIG_DM9000 is not set
 CONFIG_DECOMPRESS_LZMA=y
 CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
 # CONFIG_DM9000 is not set
-CONFIG_EXT2_FS=y
+CONFIG_EXT4_FS=y
 # CONFIG_FPE_FASTFPE is not set
 # CONFIG_FPE_NWFPE is not set
 CONFIG_FRAME_POINTER=y
 # CONFIG_FPE_FASTFPE is not set
 # CONFIG_FPE_NWFPE is not set
 CONFIG_FRAME_POINTER=y
index 0e7a8450021808282033983317ea8a9f51aeba11..f7beb95920eb2ec0450daa672a8c111860d7e3cc 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
-FEATURES:=targz pci ext2
+FEATURES:=targz pci ext4
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
 LINUX_VERSION:=2.6.32.25
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
 LINUX_VERSION:=2.6.32.25
index e3c93a8f0a8c7b4cde861c2f8ace4b6ff715b53c..c429e2e7673982b371bfe27314a896e1873decd1 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ep93xx
 BOARDNAME:=Cirrus Logic EP93xx
 ARCH:=arm
 BOARD:=ep93xx
 BOARDNAME:=Cirrus Logic EP93xx
-FEATURES:=squashfs jffs2 ext2 targz usb
+FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
 
 LINUX_VERSION:=2.6.36
 CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
 
 LINUX_VERSION:=2.6.36
index ef9a47c7e89ec76b931a978f091a5d4549a55b2e..3fe6f0c6ad298ee1ee8a8c45dcd1f76295ee0b88 100644 (file)
@@ -1,8 +1,7 @@
 CONFIG_ATA=y
 CONFIG_BLK_DEV_SD=y
 CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
 CONFIG_ATA=y
 CONFIG_BLK_DEV_SD=y
 CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_JBD=y
 CONFIG_REISERFS_FS=y
 CONFIG_SATA_VIA=y
 CONFIG_JBD=y
 CONFIG_REISERFS_FS=y
 CONFIG_SATA_VIA=y
index 0f33463978447530faf95a01a774068cc832f473..4436bed4e90406526cc8a5166f9dfbfc72a359b2 100644 (file)
@@ -44,8 +44,7 @@ CONFIG_DEVPORT=y
 # CONFIG_DLCI is not set
 # CONFIG_DM9000 is not set
 CONFIG_DNOTIFY=y
 # CONFIG_DLCI is not set
 # CONFIG_DM9000 is not set
 CONFIG_DNOTIFY=y
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 # CONFIG_FPE_FASTFPE is not set
 # CONFIG_FPE_NWFPE is not set
 CONFIG_FRAME_POINTER=y
 # CONFIG_FPE_FASTFPE is not set
 # CONFIG_FPE_NWFPE is not set
 CONFIG_FRAME_POINTER=y
index ee9fa6c09ac9ff01219f12d995963ba80f769c79..152e51e58341f093d300eac54f903923d30ee0ae 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
-FEATURES:=targz ext2
+FEATURES:=targz ext4
 
 LINUX_VERSION:=2.6.30.10
 
 
 LINUX_VERSION:=2.6.30.10
 
index 0766214ceb5757e1e20f83d1d38055310246badb..976d495a665a792ee0102fb1bad4ab2c6e6c9f6a 100644 (file)
@@ -145,16 +145,7 @@ CONFIG_DNOTIFY=y
 CONFIG_DUMMY_CONSOLE=y
 # CONFIG_EASYCAP is not set
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_DUMMY_CONSOLE=y
 # CONFIG_EASYCAP is not set
 CONFIG_ENABLE_MUST_CHECK=y
-CONFIG_EXT2_FS=y
-CONFIG_EXT2_FS_POSIX_ACL=y
-# CONFIG_EXT2_FS_SECURITY is not set
-CONFIG_EXT2_FS_XATTR=y
-CONFIG_EXT2_FS_XIP=y
-CONFIG_EXT3_DEFAULTS_TO_ORDERED=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT3_FS_POSIX_ACL=y
-# CONFIG_EXT3_FS_SECURITY is not set
-CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
index 086968283e3726712f5a44208dd685b7293c5ffb..45ee7dc0a3e6ecb66cbcc7ff4df0b65dc27802cc 100644 (file)
@@ -171,16 +171,7 @@ CONFIG_DUMMY_CONSOLE=y
 # CONFIG_ECRYPT_FS is not set
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXPORTFS=m
 # CONFIG_ECRYPT_FS is not set
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXPORTFS=m
-CONFIG_EXT2_FS=y
-CONFIG_EXT2_FS_POSIX_ACL=y
-# CONFIG_EXT2_FS_SECURITY is not set
-CONFIG_EXT2_FS_XATTR=y
-CONFIG_EXT2_FS_XIP=y
-CONFIG_EXT3_DEFAULTS_TO_ORDERED=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT3_FS_POSIX_ACL=y
-# CONFIG_EXT3_FS_SECURITY is not set
-CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
index 69ecdbb827ef67771ecf222d6e4b23896beff42a..59c40f4e8aeef28da3827d34f1d3b56bc247987c 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 - 2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/Beagleboard
   NAME:=beagleboard
 
 define Profile/Beagleboard
   NAME:=beagleboard
-  FEATURES:=ext2 usb
+  FEATURES:=ext4 usb
 endef
 
 define Profile/Beagleboard/Description
 endef
 
 define Profile/Beagleboard/Description
index e814d792618f689392c8f1d88d45d1c248eb21fb..9fd008b11ed0ee459f4b209a4df9fa5bb423c316 100644 (file)
@@ -340,17 +340,7 @@ CONFIG_EPOLL=y
 CONFIG_EVENTFD=y
 CONFIG_EXPERIMENTAL=y
 CONFIG_EXPORTFS=m
 CONFIG_EVENTFD=y
 CONFIG_EXPERIMENTAL=y
 CONFIG_EXPORTFS=m
-# CONFIG_EXT2_FS_XATTR is not set
-# CONFIG_EXT2_FS_XIP is not set
-CONFIG_EXT2_FS=y
-# CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
-# CONFIG_EXT3_FS_XATTR is not set
-CONFIG_EXT3_FS=y
-# CONFIG_EXT4_DEBUG is not set
-CONFIG_EXT4_FS=m
-CONFIG_EXT4_FS_POSIX_ACL=y
-CONFIG_EXT4_FS_SECURITY=y
-CONFIG_EXT4_FS_XATTR=y
+CONFIG_EXT4_FS=y
 # CONFIG_EZX_PCAP is not set
 CONFIG_FAIR_GROUP_SCHED=y
 CONFIG_FAT_DEFAULT_CODEPAGE=437
 # CONFIG_EZX_PCAP is not set
 CONFIG_FAIR_GROUP_SCHED=y
 CONFIG_FAT_DEFAULT_CODEPAGE=437
index a79aa803cf20017d55a148e0e5378901edc01a67..8c9688793e3b7a0d12ef386449a9fba406a5a71d 100644 (file)
@@ -107,12 +107,7 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXPORTFS=m
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXPORTFS=m
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT4_FS=m
-CONFIG_EXT4_FS_POSIX_ACL=y
-CONFIG_EXT4_FS_SECURITY=y
-CONFIG_EXT4_FS_XATTR=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
index a9e14cecb562a836d23eafe3f269715704ca0b36..dbe1325908f61d93cfd306020c0ea1f1a76260d6 100644 (file)
@@ -119,12 +119,7 @@ CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXPORTFS=m
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXPORTFS=m
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT4_FS=m
-CONFIG_EXT4_FS_POSIX_ACL=y
-CONFIG_EXT4_FS_SECURITY=y
-CONFIG_EXT4_FS_XATTR=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
index d170448604a5c1a370b1ffa49c92ceff44d224f5..ec77f5ef36ab4446bae860d2fe4067e316554472 100644 (file)
@@ -10,8 +10,7 @@ CONFIG_BLK_DEV_SD=y
 # CONFIG_DM_SNAPSHOT is not set
 # CONFIG_DM_UEVENT is not set
 # CONFIG_DM_ZERO is not set
 # CONFIG_DM_SNAPSHOT is not set
 # CONFIG_DM_UEVENT is not set
 # CONFIG_DM_ZERO is not set
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_JBD=y
 CONFIG_LBD=y
 CONFIG_MD_AUTODETECT=y
 CONFIG_JBD=y
 CONFIG_LBD=y
 CONFIG_MD_AUTODETECT=y
index f7aefc7d1e9f9cb73910eff6ec83b54bdb1a88a8..e11c339f405136b945890d16e152e972db07e378 100644 (file)
@@ -61,7 +61,7 @@ CONFIG_DEVPORT=y
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
-CONFIG_EXT2_FS=y
+CONFIG_EXT4_FS=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
index 9ca6f883228ef4ea0306ae4379c743812e8e97a0..7e90ea71a6d2ab2adb267e39c02a391b583eccc0 100644 (file)
@@ -63,7 +63,7 @@ CONFIG_DEVPORT=y
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
-CONFIG_EXT2_FS=y
+CONFIG_EXT4_FS=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
index a274d79a447382fac4acd9833bb17c515b2ea48a..60e25137a7b14089a79f1d7e00c8c490f90969b0 100644 (file)
@@ -63,7 +63,7 @@ CONFIG_DEVPORT=y
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
-CONFIG_EXT2_FS=y
+CONFIG_EXT4_FS=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
index b58b90324e1f1c7efab6f699ced9bdb914c78725..8e7c201c742a65097a08ee9df176c01c1a93961e 100644 (file)
@@ -67,7 +67,7 @@ CONFIG_DEVPORT=y
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
-CONFIG_EXT2_FS=y
+CONFIG_EXT4_FS=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 # CONFIG_FSNOTIFY is not set
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
index 68c5f872858146a61adffc306b66dff38befad34..1be7f6dea417b95a1c2a9ce5cc257be27eae5ca9 100644 (file)
@@ -74,6 +74,7 @@ CONFIG_ELF_CORE=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
 CONFIG_EXT2_FS=y
 CONFIG_EXT3_FS=y
 # CONFIG_ENABLE_WARN_DEPRECATED is not set
 CONFIG_EXT2_FS=y
 CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FB_CFB_FILLRECT=y
 CONFIG_FB_CFB_IMAGEBLIT=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FB_CFB_FILLRECT=y
 CONFIG_FB_CFB_IMAGEBLIT=y
index 40cb746f312e143aba0a66409085d041f769819c..94a08f3bd0ceb0239f88b9afebd7e96928a83721 100644 (file)
@@ -20,7 +20,7 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext2 audio
+FEATURES:=ext4 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 LINUX_VERSION:=2.6.32.25
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 LINUX_VERSION:=2.6.32.25
index 3cbed95426c0219d639f040185f8228d2b9a263a..5ff1d246fb246aca4931afae8dd25f9c35b9ef0b 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
+FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.36
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 0b0981b89402c70101e7584aa78adef9178046f9..eff0b2800b65dce66fb4cff37a4ebd5f8700d9aa 100644 (file)
@@ -101,7 +101,7 @@ CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 # CONFIG_ELPLUS is not set
 # CONFIG_EUROTECH_WDT is not set
 CONFIG_ELF_CORE=y
 # CONFIG_ELPLUS is not set
 # CONFIG_EUROTECH_WDT is not set
-CONFIG_EXT2_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_FIRMWARE_IN_KERNEL=y
 CONFIG_FIRMWARE_MEMMAP=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FIRMWARE_IN_KERNEL=y
 CONFIG_FIRMWARE_MEMMAP=y
 CONFIG_FIX_EARLYCON_MEM=y
index 8467f48a4f283203559c2fbdd228314a0425a80b..3557e63c2fcc7d5df00d2ebeba33338daeef881b 100644 (file)
@@ -1,7 +1,7 @@
 config X86_GRUB_IMAGES
        bool "Build GRUB images (Linux x86 or x86_64 host only)"
        depends TARGET_x86 && !TARGET_x86_olpc
 config X86_GRUB_IMAGES
        bool "Build GRUB images (Linux x86 or x86_64 host only)"
        depends TARGET_x86 && !TARGET_x86_olpc
-       depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+       depends TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
        select PACKAGE_grub
        default y
 
        select PACKAGE_grub
        default y
 
@@ -35,21 +35,21 @@ config X86_VDI_IMAGES
        bool "Build VirtualBox image files (VDI)"
        depends X86_GRUB_IMAGES
        depends TARGET_x86_generic
        bool "Build VirtualBox image files (VDI)"
        depends X86_GRUB_IMAGES
        depends TARGET_x86_generic
-       depends TARGET_ROOTFS_EXT2FS
+       depends TARGET_ROOTFS_EXT4FS
        select PACKAGE_kmod-pcnet32
 
 config X86_VMDK_IMAGES
        bool "Build VMware image files (VMDK)"
        depends X86_GRUB_IMAGES
        depends TARGET_x86_generic
        select PACKAGE_kmod-pcnet32
 
 config X86_VMDK_IMAGES
        bool "Build VMware image files (VMDK)"
        depends X86_GRUB_IMAGES
        depends TARGET_x86_generic
-       depends TARGET_ROOTFS_EXT2FS
+       depends TARGET_ROOTFS_EXT4FS
        select PACKAGE_kmod-e1000
 
 
 config OLPC_BOOTSCRIPT_IMAGES
        bool "Build images with bootscript"
        depends TARGET_x86_olpc
        select PACKAGE_kmod-e1000
 
 
 config OLPC_BOOTSCRIPT_IMAGES
        bool "Build images with bootscript"
        depends TARGET_x86_olpc
-       depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+       depends TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
 
 
 config TARGET_IMAGES_PAD
 
 
 config TARGET_IMAGES_PAD
index b5297bbff8b1a745d301d9b27959dc9380ce032a..57d7b0b46d0369502080c23346acb02e5920b4f5 100644 (file)
@@ -35,8 +35,8 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
 
   BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
 
 
   BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
 
-  define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2 rootwait
+  define Image/cmdline/ext4
+    root=$(ROOTPART) rootfstype=ext4 rootwait
   endef
   
   define Image/cmdline/jffs2-64k
   endef
   
   define Image/cmdline/jffs2-64k
@@ -88,8 +88,8 @@ ROOTDELAY=10
 
 ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
 
 
 ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
 
-  define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2 rootwait
+  define Image/cmdline/ext4
+    root=$(ROOTPART) rootfstype=ext4 rootwait
   endef
 
   define Image/cmdline/jffs2-64k
   endef
 
   define Image/cmdline/jffs2-64k
@@ -141,7 +141,7 @@ endef
 ifneq ($(CONFIG_X86_VDI_IMAGES),)
   define Image/Build/vdi
     # left here because the image builder doesnt need these
 ifneq ($(CONFIG_X86_VDI_IMAGES),)
   define Image/Build/vdi
     # left here because the image builder doesnt need these
-    ifeq ($(1),ext2)
+    ifeq ($(1),ext4)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
                qemu-img convert -f raw -O vdi \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
                qemu-img convert -f raw -O vdi \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -155,7 +155,7 @@ endif
 ifneq ($(CONFIG_X86_VMDK_IMAGES),)
   define Image/Build/vmdk
     # left here because the image builder doesnt need these
 ifneq ($(CONFIG_X86_VMDK_IMAGES),)
   define Image/Build/vmdk
     # left here because the image builder doesnt need these
-    ifeq ($(1),ext2)
+    ifeq ($(1),ext4)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
                qemu-img convert -f raw -O vmdk \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
                qemu-img convert -f raw -O vmdk \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -184,7 +184,7 @@ define Image/Build
   endif
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
   endif
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
-  ifeq ($(1),ext2)
+  ifeq ($(1),ext4)
        gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
        gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
   endif
        gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
        gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
   endif
index 5e0e37cc9695f7fafcb505146939f7841f19e5ce..95aa8ccc7c4399645c4e1dbc6805674cb5aae1b3 100644 (file)
@@ -67,8 +67,7 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 # CONFIG_FB_JZ4740 is not set
 CONFIG_FB_SYS_COPYAREA=y
 CONFIG_FAT_FS=y
 # CONFIG_FB_JZ4740 is not set
 CONFIG_FB_SYS_COPYAREA=y
index 62052f438ff62510a8621719528009fa8de6d947..ea088ac5f6d5c133718be64d351a038b2592f9f9 100644 (file)
@@ -68,8 +68,7 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 # CONFIG_FB_JZ4740 is not set
 CONFIG_FB_SYS_COPYAREA=y
 CONFIG_FAT_FS=y
 # CONFIG_FB_JZ4740 is not set
 CONFIG_FB_SYS_COPYAREA=y
index a6336694475416de9dd5f9a8d8e1163c18f31680..70b205b9d29764d1cfe67830ae7eccf03b092f05 100644 (file)
@@ -69,8 +69,7 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
+CONFIG_EXT4_FS=y
 CONFIG_FAT_FS=y
 # CONFIG_FB_JZ4740 is not set
 CONFIG_FB_SYS_COPYAREA=y
 CONFIG_FAT_FS=y
 # CONFIG_FB_JZ4740 is not set
 CONFIG_FB_SYS_COPYAREA=y