ubifs: remove breaking commas from ubi calls
authorLuka Perkov <luka@openwrt.org>
Tue, 15 Oct 2013 21:37:31 +0000 (21:37 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 15 Oct 2013 21:37:31 +0000 (21:37 +0000)
The extra commas get output by the shell resulting in errors since
the commands that get called with those extra commas are then
malformed.

Signed-off-by: Joris de Vries <joris@apptrician.nl>
SVN-Revision: 38419

include/image.mk

index c79d82353810b38685df95be74b0a2793505f106..8f895a3435cf4ff42460412ffd70700cdf5cfc50 100644 (file)
@@ -125,7 +125,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
                $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
                        $(if $($(PROFILE)_UBIFS_OPTS), \
                                $(shell echo $($(PROFILE)_UBIFS_OPTS)), \
-                               $(shell echo $(UBIFS_OPTS)), \
+                               $(shell echo $(UBIFS_OPTS)) \
                        ) \
                        $(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
                $(STAGING_DIR_HOST)/bin/ubinize \
                        $(if $($(PROFILE)_UBI_OPTS), \
                                $(shell echo $($(PROFILE)_UBI_OPTS)), \
-                               $(shell echo $(UBI_OPTS)), \
+                               $(shell echo $(UBI_OPTS)) \
                        ) \
                        -o $(KDIR)/root.ubi \
                        ubinize.cfg \