ar71xx/image: add Build/mktplinkfw as buildstep for new build code
authorFelix Fietkau <nbd@openwrt.org>
Wed, 25 Mar 2015 17:58:05 +0000 (17:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 25 Mar 2015 17:58:05 +0000 (17:58 +0000)
Use `mktplinkfw sysupgrade` or `mktplinkfw factory` or
`mktplinkfw image`

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 44998

target/linux/ar71xx/image/Makefile

index 204a6e7ec2f359735d0fa7dc1901667e94cf8eb8..4023b1af9234f3e0d80873346b2e54a5e5d51a6b 100644 (file)
@@ -45,6 +45,26 @@ define Build/netgear-image
        mv $@.new $@
 endef
 
+# combine kernel and rootfs into one image
+# -a align the rootfs start on an <align> bytes boundary
+# -j add jffs2 end-of-filesystem markers
+# -s strip padding from end of the image
+# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
+define Build/mktplinkfw
+       $(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+               -k $(word 1,$^) \
+               -r $@ \
+               -o $@.new \
+               -a $(call rootfs_align,$(FILESYSTEM)) \
+               $(if $(findstring sysupgrade,$1),-j -X 0x40000) \
+               $(if $(findstring factory,$1),-j -X 0x40000 -s) \
+               $(if $(findstring initramfs,$1),-s -c)
+       @mv $@.new $@
+endef
+
+DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT
+
 define Device/Default
   BOARDNAME :=
   DEVICE_PROFILE = $$(BOARDNAME)