kernel: bump 5.4 to 5.4.171
authorDavid Bauer <mail@david-bauer.net>
Thu, 13 Jan 2022 09:06:20 +0000 (10:06 +0100)
committerDavid Bauer <mail@david-bauer.net>
Thu, 13 Jan 2022 19:30:59 +0000 (20:30 +0100)
Compile-tested: ath79-generic ipq40xx-generic
Run-tested: ath79-generic

Signed-off-by: David Bauer <mail@david-bauer.net>
17 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.4/950-0030-lan78xx-Enable-LEDs-and-auto-negotiation.patch
target/linux/bcm27xx/patches-5.4/950-0043-MMC-added-alternative-MMC-driver.patch
target/linux/bcm27xx/patches-5.4/950-0111-lan78xx-Read-initial-EEE-status-from-DT.patch
target/linux/bcm27xx/patches-5.4/950-0117-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
target/linux/bcm27xx/patches-5.4/950-0118-lan78xx-Move-enabling-of-EEE-into-PHY-init-code.patch
target/linux/bcm27xx/patches-5.4/950-0119-Add-rpi-poe-fan-driver.patch
target/linux/bcm27xx/patches-5.4/950-0132-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/bcm27xx/patches-5.4/950-0137-lan78xx-EEE-support-is-now-a-PHY-property.patch
target/linux/bcm27xx/patches-5.4/950-0145-lan78xx-use-default-alignment-for-rx-buffers.patch
target/linux/bcm27xx/patches-5.4/950-0211-usb-xhci-Show-that-the-VIA-VL805-supports-LPM.patch
target/linux/bcm27xx/patches-5.4/950-0264-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.4/950-0993-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/bcm27xx/patches-5.4/950-1031-net-lan78xx-Ack-pending-PHY-ints-when-resetting.patch
target/linux/generic/pending-5.4/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch

index f8da54f606d42d5800dcdf8b9dd26ec781bf0b49..bb1bba06be976d4bba74ec93bc60f0fb5d22ecbc 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .168
+LINUX_VERSION-5.4 = .171
 
-LINUX_KERNEL_HASH-5.4.168 = ecb79ac4d465623560a6da31e3b0a0cf3fbb7c09e9ba88f06567436757191181
+LINUX_KERNEL_HASH-5.4.171 = afbcc8ed7d85485af299567f307b03057ffff3ec7bee02a21c33933d435b4958
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 8a4d3f21fad4083ef256cf71742a58472b3d59a9..2ce7e7e30e77a1b9bb57d88fff9483219f9185b1 100644 (file)
@@ -93,7 +93,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  static const char hcd_name[] = "xhci_hcd";
  
  static struct hc_driver __read_mostly xhci_pci_hc_driver;
-@@ -331,6 +371,873 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -334,6 +374,873 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -967,7 +967,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -372,6 +1279,27 @@ static int xhci_pci_probe(struct pci_dev
+@@ -375,6 +1282,27 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -995,7 +995,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        driver = (struct hc_driver *)id->driver_data;
  
        /* Prevent runtime suspending between USB-2 and USB-3 initialization */
-@@ -433,6 +1361,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -436,6 +1364,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
@@ -1012,7 +1012,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        xhci = hcd_to_xhci(pci_get_drvdata(dev));
        xhci->xhc_state |= XHCI_STATE_REMOVING;
  
-@@ -572,6 +1510,11 @@ static int xhci_pci_resume(struct usb_hc
+@@ -575,6 +1513,11 @@ static int xhci_pci_resume(struct usb_hc
        if (pdev->vendor == PCI_VENDOR_ID_INTEL)
                usb_enable_intel_xhci_ports(pdev);
  
index 0bca7ab4d5dca383d6c8f190c6fd98cc3c39ba8d..cf6209964967970d871893615fbb0140ae830320 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -299,6 +299,7 @@ static void xhci_pci_quirks(struct devic
+@@ -302,6 +302,7 @@ static void xhci_pci_quirks(struct devic
            pdev->device == 0x0015) {
                xhci->quirks |= XHCI_RESET_ON_RESUME;
                xhci->quirks |= XHCI_ZERO_64B_REGS;
index 3b1d4332d648058d974219e89c0b04564b9acb5b..1964988c75b6e2860ffdc528e77ec750fdc13c8d 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2469,6 +2469,11 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2471,6 +2471,11 @@ static int lan78xx_reset(struct lan78xx_
        int ret = 0;
        unsigned long timeout;
        u8 sig;
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_LRST_;
-@@ -2522,6 +2527,9 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2524,6 +2529,9 @@ static int lan78xx_reset(struct lan78xx_
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_MEF_;
@@ -36,7 +36,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        ret = lan78xx_write_reg(dev, HW_CFG, buf);
  
        ret = lan78xx_read_reg(dev, USB_CFG0, &buf);
-@@ -2577,6 +2585,9 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2579,6 +2587,9 @@ static int lan78xx_reset(struct lan78xx_
                        buf |= MAC_CR_AUTO_DUPLEX_ | MAC_CR_AUTO_SPEED_;
                }
        }
index 378c605d3527147b3cee74497902af7a68b2630c..ce51e004c55464f2595f89b4941427a8e5ad347f 100644 (file)
@@ -279,7 +279,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  }
 --- a/drivers/mmc/core/host.c
 +++ b/drivers/mmc/core/host.c
-@@ -434,15 +434,30 @@ struct mmc_host *mmc_alloc_host(int extr
+@@ -443,15 +443,30 @@ struct mmc_host *mmc_alloc_host(int extr
  {
        int err;
        struct mmc_host *host;
index c4200203da5eb1d2b9e102e035fd59d08ae80567..796ec2fe8fd033f75924059e0999d4c3f33b366a 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2651,6 +2651,22 @@ static int lan78xx_open(struct net_devic
+@@ -2653,6 +2653,22 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 735e9d3f8a45788aa8f7ef2c883c7b6d336d3f9c..53105698384aa61fa0982929953bd4e6d9dd12c6 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -425,6 +425,15 @@ static int msg_level = -1;
+@@ -427,6 +427,15 @@ static int msg_level = -1;
  module_param(msg_level, int, 0);
  MODULE_PARM_DESC(msg_level, "Override default message level");
  
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -2933,8 +2942,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2935,8 +2944,14 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_RX_CSUM_ENABLE)
                dev->net->features |= NETIF_F_RXCSUM;
  
index 29a5d22eb5f8448125a877a04e958f2e75db321d..7b931de951aa61ea68deeebb62405367096bdc0e 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2183,6 +2183,22 @@ static int lan78xx_phy_init(struct lan78
+@@ -2185,6 +2185,22 @@ static int lan78xx_phy_init(struct lan78
        mii_adv_to_linkmode_adv_t(fc, mii_adv);
        linkmode_or(phydev->advertising, fc, phydev->advertising);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        if (phydev->mdio.dev.of_node) {
                u32 reg;
                int len;
-@@ -2660,22 +2676,6 @@ static int lan78xx_open(struct net_devic
+@@ -2662,22 +2678,6 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 8a1f57ad0156544ffe6018a04b2022be6c88db81..e8e3ddb6d79ece60bb6f250e7682cf8f4648b7af 100644 (file)
@@ -108,7 +108,7 @@ Signed-off-by: Serge Schneider <serge@raspberrypi.org>
 +the fan to the user space through the hwmon sysfs interface.
 --- a/drivers/hwmon/Kconfig
 +++ b/drivers/hwmon/Kconfig
-@@ -1356,6 +1356,17 @@ config SENSORS_RASPBERRYPI_HWMON
+@@ -1357,6 +1357,17 @@ config SENSORS_RASPBERRYPI_HWMON
          This driver can also be built as a module. If so, the module
          will be called raspberrypi-hwmon.
  
index 19ea77e99cdbd490c89740fc2439dd395d58814d..fe073c66df1d00221d692e1fccba1a46c56a7180 100644 (file)
@@ -15,7 +15,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  1 file changed, 11 insertions(+), 1 deletion(-)
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -434,6 +434,11 @@ static bool enable_tso;
+@@ -436,6 +436,11 @@ static bool enable_tso;
  module_param(enable_tso, bool, 0644);
  MODULE_PARM_DESC(enable_tso, "Enables TCP segmentation offload");
  
@@ -27,7 +27,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3776,7 +3781,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3778,7 +3783,12 @@ static int lan78xx_probe(struct usb_inte
        netdev->max_mtu = MAX_SINGLE_PACKET_SIZE;
        netif_set_gso_max_size(netdev, MAX_SINGLE_PACKET_SIZE - MAX_HEADER);
  
index b30d95694be5fb213592ac2566a1d1f929879215..719264994e9536eb1833cc8f3f94111bdf3524a9 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2188,7 +2188,7 @@ static int lan78xx_phy_init(struct lan78
+@@ -2190,7 +2190,7 @@ static int lan78xx_phy_init(struct lan78
        mii_adv_to_linkmode_adv_t(fc, mii_adv);
        linkmode_or(phydev->advertising, fc, phydev->advertising);
  
index e1f21e3971347a415a83d3c98f632c9d1386d33f..6784c906e2351b93b0a59750b0785e9815906f0b 100644 (file)
@@ -12,7 +12,7 @@ in both dwc_otg and in ipv6 processing.
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -3177,7 +3177,7 @@ static int rx_submit(struct lan78xx_net
+@@ -3179,7 +3179,7 @@ static int rx_submit(struct lan78xx_net
        size_t size = dev->rx_urb_size;
        int ret = 0;
  
index 4d8f7b98fd8eb5534087a78335788ebf0259a1e1..0bd2f1030a721bab72a47b605e45637cc840079b 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -268,6 +268,10 @@ static void xhci_pci_quirks(struct devic
+@@ -271,6 +271,10 @@ static void xhci_pci_quirks(struct devic
                        pdev->device == 0x3432)
                xhci->quirks |= XHCI_BROKEN_STREAMS;
  
index 908b906d3e0757215f792a53a971e1fe6a34faa7..e28938a0507a113c1340e1f8c49f24134bcba826 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -269,8 +269,10 @@ static void xhci_pci_quirks(struct devic
+@@ -272,8 +272,10 @@ static void xhci_pci_quirks(struct devic
                xhci->quirks |= XHCI_BROKEN_STREAMS;
  
        if (pdev->vendor == PCI_VENDOR_ID_VIA &&
index 7632e3f703276b81877e2df1a0343e56280f61c2..309f1a8989af83f161c5d0b3f48c76149cb538be 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -272,6 +272,7 @@ static void xhci_pci_quirks(struct devic
+@@ -275,6 +275,7 @@ static void xhci_pci_quirks(struct devic
                        pdev->device == 0x3483) {
                xhci->quirks |= XHCI_LPM_SUPPORT;
                xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
index 49d843d4d8fab017d42622253d4c46952c4cd212..f0d23f9be1acf1fdff3d8b3e71db4fd7b89423f7 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -1181,6 +1181,9 @@ static int lan78xx_link_reset(struct lan
+@@ -1183,6 +1183,9 @@ static int lan78xx_link_reset(struct lan
        if (unlikely(ret < 0))
                return -EIO;
  
index 8cf36addeba07aa4eb12f5fc1e015984d6061e41..d21258e590b1e02a771738e849eacdb96ecc4187 100644 (file)
@@ -185,7 +185,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -6056,6 +6087,8 @@ static int ip6_route_dev_notify(struct n
+@@ -6084,6 +6115,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -194,7 +194,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -6067,6 +6100,7 @@ static int ip6_route_dev_notify(struct n
+@@ -6095,6 +6128,7 @@ static int ip6_route_dev_notify(struct n
                in6_dev_put_clear(&net->ipv6.ip6_null_entry->rt6i_idev);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                in6_dev_put_clear(&net->ipv6.ip6_prohibit_entry->rt6i_idev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                in6_dev_put_clear(&net->ipv6.ip6_blk_hole_entry->rt6i_idev);
  #endif
        }
-@@ -6259,6 +6293,8 @@ static int __net_init ip6_route_net_init
+@@ -6287,6 +6321,8 @@ static int __net_init ip6_route_net_init
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        net->ipv6.fib6_has_custom_rules = false;
@@ -211,7 +211,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        net->ipv6.ip6_prohibit_entry = kmemdup(&ip6_prohibit_entry_template,
                                               sizeof(*net->ipv6.ip6_prohibit_entry),
                                               GFP_KERNEL);
-@@ -6269,11 +6305,21 @@ static int __net_init ip6_route_net_init
+@@ -6297,11 +6333,21 @@ static int __net_init ip6_route_net_init
                         ip6_template_metrics, true);
        INIT_LIST_HEAD(&net->ipv6.ip6_prohibit_entry->rt6i_uncached);
  
@@ -234,7 +234,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
-@@ -6297,6 +6343,8 @@ out:
+@@ -6325,6 +6371,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -243,7 +243,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -6316,6 +6364,7 @@ static void __net_exit ip6_route_net_exi
+@@ -6344,6 +6392,7 @@ static void __net_exit ip6_route_net_exi
        kfree(net->ipv6.ip6_null_entry);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
@@ -251,7 +251,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        kfree(net->ipv6.ip6_blk_hole_entry);
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
-@@ -6393,6 +6442,9 @@ void __init ip6_route_init_special_entri
+@@ -6421,6 +6470,9 @@ void __init ip6_route_init_special_entri
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);