uboot-envtools: adds r7800 uboot env support
authorAnsuel Smith <ansuelsmth@gmail.com>
Sun, 30 Sep 2018 17:21:39 +0000 (19:21 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Oct 2018 00:12:06 +0000 (02:12 +0200)
This fix and adds support for r7800 uboot env

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ipq806x

index 2f8dd0ae64ffb2ad737527710b859a6bfbed1357..7cd9e9fb631a7808d69d8267cabc9578d45ed26c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2018.03
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
index 4618aac892d98bf377d3a53d81c9ca55ae702f7d..c27bea71c156761210d49e520ec5603bd99e63b1 100644 (file)
@@ -34,6 +34,9 @@ case "$board" in
 linksys,ea8500)
        ubootenv_add_uci_config "/dev/mtd10" "0x0" "0x20000" "0x20000"
        ;;
+netgear,r7800)
+       ubootenv_add_uci_config "/dev/mtd2" "0x0" "0x040000" "0x20000"
+       ;;
 qcom,ipq8064-ap148 |\
 qcom,ipq8064-db149)
        ubootenv_add_uci_config $(ubootenv_mtdinfo)