ipq40xx: add Edgecore ECW5211 support
authorRobert Marko <robert.marko@sartura.hr>
Mon, 7 Sep 2020 10:50:45 +0000 (12:50 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 17 Sep 2020 06:43:03 +0000 (08:43 +0200)
This patch adds support for the Edgecore ECW5211 indoor AP.

Specification:
- SoC: Qualcomm Atheros IPQ4018 ARMv7-A 4x Cortex A-7
- RAM: 256MB DDR3
- NOR Flash: 16MB SPI NOR
- NAND Flash: 128MB MX35LFxGE4AB SPI-NAND
- Ethernet: 2 x 1G via Q8075 PHY connected to ethernet adapter via PSGMII (802.3af POE IN on eth0)
- USB: 1 x USB 3.0 SuperSpeed
- WLAN: Built-in IPQ4018 (2x2 802.11bng, 2x2 802.11 acn)
- CC2540 BLE connected to USB 2.0 port
- Atmel AT97SC3205T I2C TPM

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
package/boot/uboot-envtools/files/ipq40xx
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-edgecore_ecw5211.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/01_leds
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ecw5211.dts [new file with mode: 0644]
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch

index f427661cf7119fead3ab82b17111e9d7381514fc..76a334611045e1027170c92c2d72b8ba36666348 100644 (file)
@@ -32,6 +32,7 @@ ubootenv_mtdinfo () {
 
 case "$board" in
 alfa-network,ap120c-ac |\
+edgecore,ecw5211 |\
 glinet,gl-b1300 |\
 openmesh,a42 |\
 openmesh,a62)
index a7969101865ed07c6baac60d3cb777d2673dcf90..963cf2d7c4ef836be272168d2ae04374e261de0c 100644 (file)
@@ -31,6 +31,7 @@ ALLWIFIBOARDS:= \
        buffalo_wtr-m2133hp \
        cellc_rtl30vw \
        dlink_dap2610 \
+       edgecore_ecw5211 \
        edgecore_ecw5410 \
        engenius_eap2200 \
        engenius_emd1 \
@@ -106,6 +107,7 @@ $(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater
 $(eval $(call generate-ipq-wifi-package,buffalo_wtr-m2133hp,Buffalo WTR-M2133HP))
 $(eval $(call generate-ipq-wifi-package,cellc_rtl30vw, Cell C RTL30VW))
 $(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
+$(eval $(call generate-ipq-wifi-package,edgecore_ecw5211,Edgecore ECW5211))
 $(eval $(call generate-ipq-wifi-package,edgecore_ecw5410,Edgecore ECW5410))
 $(eval $(call generate-ipq-wifi-package,engenius_eap2200,EnGenius EAP2200))
 $(eval $(call generate-ipq-wifi-package,engenius_emd1,EnGenius EMD1))
diff --git a/package/firmware/ipq-wifi/board-edgecore_ecw5211.qca4019 b/package/firmware/ipq-wifi/board-edgecore_ecw5211.qca4019
new file mode 100644 (file)
index 0000000..340cfcc
Binary files /dev/null and b/package/firmware/ipq-wifi/board-edgecore_ecw5211.qca4019 differ
index 0a128e8cbcb5a766c19006a5fa1b15327b4dbf32..e9e0de9da9fc5c06dbb3c7d1377aa2e91827f3aa 100755 (executable)
@@ -62,6 +62,7 @@ zyxel,nbg6617)
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "${boardname}:green:wlan2G" "phy0tpt"
        ucidef_set_led_wlan "wlan5g" "WLAN5G" "${boardname}:green:wlan5G" "phy1tpt"
        ;;
+edgecore,ecw5211 |\
 zyxel,wre6606)
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "${boardname}:green:wlan2g" "phy0tpt"
        ucidef_set_led_wlan "wlan5g" "WLAN5G" "${boardname}:green:wlan5g" "phy1tpt"
index 61d02a17bcc935a55cd80022f4c2abfe0d0eba15..571479aaf210e897d85d3e7dc5e9f295db087118 100755 (executable)
@@ -38,6 +38,7 @@ ipq40xx_setup_interfaces()
                ;;
        asus,map-ac2200|\
        cilab,meshpoint-one|\
+       edgecore,ecw5211|\
        openmesh,a42|\
        openmesh,a62)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
index 8df7990f2e4d829641c03be073f2c71cf63df945..d85424142b306dd040169765d0f47108faa35756 100644 (file)
@@ -93,6 +93,7 @@ case "$FIRMWARE" in
        cellc,rtl30vw |\
        compex,wpj419 |\
        compex,wpj428 |\
+       edgecore,ecw5211 |\
        engenius,eap1300 |\
        engenius,eap2200 |\
        openmesh,a42 |\
@@ -186,6 +187,7 @@ case "$FIRMWARE" in
        cellc,rtl30vw |\
        compex,wpj419 |\
        compex,wpj428 |\
+       edgecore,ecw5211 |\
        engenius,eap1300 |\
        engenius,eap2200 |\
        openmesh,a42 |\
index 5b89710a2255cdfc48c90b360bca316a5e99dedb..ae5a0a7c1b3f4baced6033a8eacaa53469ccdb67 100644 (file)
@@ -66,6 +66,7 @@ platform_do_upgrade() {
        avm,fritzrepeater-3000 |\
        buffalo,wtr-m2133hp |\
        cilab,meshpoint-one |\
+       edgecore,ecw5211 |\
        engenius,eap2200 |\
        mobipromo,cm520-79f |\
        qxwlan,e2600ac-c2)
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ecw5211.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ecw5211.dts
new file mode 100644 (file)
index 0000000..3f7e2ad
--- /dev/null
@@ -0,0 +1,325 @@
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "Edgecore ECW5211";
+       compatible = "edgecore,ecw5211";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       chosen {
+               bootargs-append = " root=/dev/ubiblock0_1";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "ecw5211:yellow:power";
+                       gpios = <&tlmm 5 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "ecw5211:green:wlan2g";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan5g {
+                       label = "ecw5211:green:wlan5g";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+
+                       pinctrl-0 = <&mdio_pins>;
+                       pinctrl-names = "default";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       status = "okay";
+
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               usb2: usb2@60f8800 {
+                       status = "okay";
+               };
+
+               usb3: usb3@8af8800 {
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+};
+
+&tlmm {
+       mdio_pins: mdio_pinmux {
+               mux_mdio {
+                       pins = "gpio53";
+                       function = "mdio";
+                       bias-pull-up;
+               };
+
+               mux_mdc {
+                       pins = "gpio52";
+                       function = "mdc";
+                       bias-pull-up;
+               };
+       };
+
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi0_pins: spi0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <2>;
+                       bias-disable;
+               };
+
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio54", "gpio4";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+
+       i2c0_pins: i2c0_pinmux {
+               mux_i2c {
+                       function = "blsp_i2c0";
+                       pins = "gpio58", "gpio59";
+                       drive-strength = <16>;
+                       bias-disable;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>, <&tlmm 4 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               status = "okay";
+
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "0:SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "0:MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "0:QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+
+                       partition@c0000 {
+                               label = "0:CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+
+                       partition@d0000 {
+                               label = "0:DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+
+                       partition@e0000 {
+                               label = "0:APPSBLENV"; /* uboot env*/
+                               reg = <0x000e0000 0x00010000>;
+                               read-only;
+                       };
+
+                       partition@f0000 {
+                               label = "0:APPSBL"; /* uboot */
+                               reg = <0x000f0000 0x00080000>;
+                               read-only;
+                       };
+
+                       partition@170000 {
+                               label = "0:ART";
+                               reg = <0x00170000 0x00010000>;
+                               read-only;
+                       };
+               };
+       };
+
+       spi-nand@1 {
+               status = "okay";
+
+               compatible = "spi-nand";
+               reg = <1>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "rootfs";
+                               reg = <0x00000000 0x04000000>;
+                       };
+               };
+       };
+};
+
+&blsp1_i2c3 {
+       status = "okay";
+
+       pinctrl-0 = <&i2c0_pins>;
+       pinctrl-names = "default";
+
+       tpm@29 {
+               compatible = "atmel,at97sc3204t";
+               reg = <0x29>;
+       };
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&gmac0 {
+       qcom,poll_required = <1>;
+       qcom,poll_required_dynamic = <1>;
+       qcom,phy_mdio_addr = <4>;
+       vlan_tag = <2 0x20>;
+};
+
+&gmac1 {
+       qcom,poll_required = <1>;
+       qcom,poll_required_dynamic = <1>;
+       qcom,phy_mdio_addr = <3>;
+       vlan_tag = <1 0x10>;
+};
+
+&wifi0 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "Edgecore-ECW5211";
+};
+
+&wifi1 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "Edgecore-ECW5211";
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
index 51e8bcc7e36df300debbea28845e70fb06388e60..127af99ce582b36fd4e7b48e993a581193102ed2 100644 (file)
@@ -344,6 +344,18 @@ define Device/dlink_dap-2610
 endef
 TARGET_DEVICES += dlink_dap-2610
 
+define Device/edgecore_ecw5211
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_TITLE := Edgecore ECW5211
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_DTS := qcom-ipq4018-ecw5211
+       DEVICE_PACKAGES := ipq-wifi-edgecore_ecw5211 kmod-tpm-i2c-atmel kmod-usb-acm uboot-envtools
+endef
+TARGET_DEVICES += edgecore_ecw5211
+
 define Device/engenius_eap1300
        $(call Device/FitImage)
        DEVICE_VENDOR := EnGenius
index d281bb468daf061f6f1c284349109e479c8a0ed8..ea45606c27a8e6c7053c9a4cf7626ac1da6c25ca 100644 (file)
@@ -8,9 +8,11 @@ Signed-off-by: John Crispin <john@phrozen.org>
  arch/arm/boot/dts/Makefile | 23 +++++++++++++++++++++++
  1 file changed, 23 insertions(+)
 
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,50 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+Index: linux-5.4.63/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-5.4.63.orig/arch/arm/boot/dts/Makefile
++++ linux-5.4.63/arch/arm/boot/dts/Makefile
+@@ -837,11 +837,51 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -20,6 +22,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4018-cs-w3-wd1200g-eup.dtb \
 +      qcom-ipq4018-ea6350v3.dtb \
 +      qcom-ipq4018-eap1300.dtb \
++      qcom-ipq4018-ecw5211.dtb \
 +      qcom-ipq4018-emd1.dtb \
 +      qcom-ipq4018-emr3500.dtb \
 +      qcom-ipq4018-ens620ext.dtb \