bcm53xx: use backported BCM5301X patches from stblinux devicetree/next
authorRafał Miłecki <zajec5@gmail.com>
Thu, 3 Dec 2015 10:19:16 +0000 (10:19 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Thu, 3 Dec 2015 10:19:16 +0000 (10:19 +0000)
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 47708

target/linux/bcm53xx/patches-4.4/030-ARM-dts-bcm5301x-Add-BCM-SVK-DT-files.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-4.4/031-ARM-dts-enable-clock-support-for-BCM5301X.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-4.4/050-ARM-dts-enable-clock-support-for-BCM5301X.patch [deleted file]
target/linux/bcm53xx/patches-4.4/083-ARM-dts-bcm5301x-Add-BCM-SVK-DT-files.patch [deleted file]

diff --git a/target/linux/bcm53xx/patches-4.4/030-ARM-dts-bcm5301x-Add-BCM-SVK-DT-files.patch b/target/linux/bcm53xx/patches-4.4/030-ARM-dts-bcm5301x-Add-BCM-SVK-DT-files.patch
new file mode 100644 (file)
index 0000000..c63627d
--- /dev/null
@@ -0,0 +1,219 @@
+From ccf0b5e37115f8675455632f583d06ea94f43539 Mon Sep 17 00:00:00 2001
+From: Jon Mason <jonmason@broadcom.com>
+Date: Mon, 2 Nov 2015 13:34:53 -0500
+Subject: [PATCH] ARM: dts: bcm5301x: Add BCM SVK DT files
+
+Add device tree files for Broadcom Northstar based SVKs.  Since the
+bcm5301x.dtsi already exists, all that is necessary is the dts files to
+enable the UARTs.  With these files, the SVKs are able to boot to shell.
+
+Signed-off-by: Jon Mason <jonmason@broadcom.com>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile       |  5 +++-
+ arch/arm/boot/dts/bcm94708.dts   | 56 +++++++++++++++++++++++++++++++++++
+ arch/arm/boot/dts/bcm94709.dts   | 56 +++++++++++++++++++++++++++++++++++
+ arch/arm/boot/dts/bcm953012k.dts | 63 ++++++++++++++++++++++++++++++++++++++++
+ 4 files changed, 179 insertions(+), 1 deletion(-)
+ create mode 100644 arch/arm/boot/dts/bcm94708.dts
+ create mode 100644 arch/arm/boot/dts/bcm94709.dts
+ create mode 100644 arch/arm/boot/dts/bcm953012k.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -75,7 +75,10 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm4709-asus-rt-ac87u.dtb \
+       bcm4709-buffalo-wxr-1900dhp.dtb \
+       bcm4709-netgear-r7000.dtb \
+-      bcm4709-netgear-r8000.dtb
++      bcm4709-netgear-r8000.dtb \
++      bcm94708.dtb \
++      bcm94709.dtb \
++      bcm953012k.dtb
+ dtb-$(CONFIG_ARCH_BCM_63XX) += \
+       bcm963138dvt.dtb
+ dtb-$(CONFIG_ARCH_BCM_CYGNUS) += \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm94708.dts
+@@ -0,0 +1,56 @@
++/*
++ *  BSD LICENSE
++ *
++ *  Copyright(c) 2015 Broadcom Corporation.  All rights reserved.
++ *
++ *  Redistribution and use in source and binary forms, with or without
++ *  modification, are permitted provided that the following conditions
++ *  are met:
++ *
++ *    * Redistributions of source code must retain the above copyright
++ *      notice, this list of conditions and the following disclaimer.
++ *    * Redistributions in binary form must reproduce the above copyright
++ *      notice, this list of conditions and the following disclaimer in
++ *      the documentation and/or other materials provided with the
++ *      distribution.
++ *    * Neither the name of Broadcom Corporation nor the names of its
++ *      contributors may be used to endorse or promote products derived
++ *      from this software without specific prior written permission.
++ *
++ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
++ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
++ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
++ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
++ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
++ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
++ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
++ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
++ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
++ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
++ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++
++/ {
++      model = "NorthStar SVK (BCM94708)";
++      compatible = "brcm,bcm94708", "brcm,bcm4708";
++
++      aliases {
++              serial0 = &uart0;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++};
++
++&uart0 {
++      status = "okay";
++};
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm94709.dts
+@@ -0,0 +1,56 @@
++/*
++ *  BSD LICENSE
++ *
++ *  Copyright(c) 2015 Broadcom Corporation.  All rights reserved.
++ *
++ *  Redistribution and use in source and binary forms, with or without
++ *  modification, are permitted provided that the following conditions
++ *  are met:
++ *
++ *    * Redistributions of source code must retain the above copyright
++ *      notice, this list of conditions and the following disclaimer.
++ *    * Redistributions in binary form must reproduce the above copyright
++ *      notice, this list of conditions and the following disclaimer in
++ *      the documentation and/or other materials provided with the
++ *      distribution.
++ *    * Neither the name of Broadcom Corporation nor the names of its
++ *      contributors may be used to endorse or promote products derived
++ *      from this software without specific prior written permission.
++ *
++ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
++ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
++ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
++ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
++ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
++ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
++ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
++ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
++ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
++ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
++ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++
++/ {
++      model = "NorthStar SVK (BCM94709)";
++      compatible = "brcm,bcm94709", "brcm,bcm4709", "brcm,bcm4708";
++
++      aliases {
++              serial0 = &uart0;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++};
++
++&uart0 {
++      status = "okay";
++};
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm953012k.dts
+@@ -0,0 +1,63 @@
++/*
++ *  BSD LICENSE
++ *
++ *  Copyright(c) 2015 Broadcom Corporation.  All rights reserved.
++ *
++ *  Redistribution and use in source and binary forms, with or without
++ *  modification, are permitted provided that the following conditions
++ *  are met:
++ *
++ *    * Redistributions of source code must retain the above copyright
++ *      notice, this list of conditions and the following disclaimer.
++ *    * Redistributions in binary form must reproduce the above copyright
++ *      notice, this list of conditions and the following disclaimer in
++ *      the documentation and/or other materials provided with the
++ *      distribution.
++ *    * Neither the name of Broadcom Corporation nor the names of its
++ *      contributors may be used to endorse or promote products derived
++ *      from this software without specific prior written permission.
++ *
++ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
++ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
++ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
++ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
++ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
++ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
++ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
++ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
++ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
++ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
++ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++
++/ {
++      model = "NorthStar SVK (BCM953012K)";
++      compatible = "brcm,bcm953012k", "brcm,brcm53012", "brcm,bcm4708";
++
++      aliases {
++              serial0 = &uart0;
++              serial1 = &uart1;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      memory {
++              reg = <0x00000000 0x10000000>;
++      };
++};
++
++&uart0 {
++      clock-frequency = <62499840>;
++      status = "okay";
++};
++
++&uart1 {
++      clock-frequency = <62499840>;
++      status = "okay";
++};
diff --git a/target/linux/bcm53xx/patches-4.4/031-ARM-dts-enable-clock-support-for-BCM5301X.patch b/target/linux/bcm53xx/patches-4.4/031-ARM-dts-enable-clock-support-for-BCM5301X.patch
new file mode 100644 (file)
index 0000000..e8dd0cd
--- /dev/null
@@ -0,0 +1,174 @@
+From cdc36b22f0e4b8badf3db14395f0aa44dcbce4b3 Mon Sep 17 00:00:00 2001
+From: Jon Mason <jonmason@broadcom.com>
+Date: Fri, 20 Nov 2015 10:17:18 -0500
+Subject: [PATCH] ARM: dts: enable clock support for BCM5301X
+
+Replace current device tree dummy clocks with real clock support for
+Broadcom Northstar SoCs.
+
+Signed-off-by: Jon Mason <jonmason@broadcom.com>
+Reviewed-by: Ray Jui <rjui@broadcom.com>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/bcm5301x.dtsi | 92 +++++++++++++++++++++++++++++++----------
+ 1 file changed, 71 insertions(+), 21 deletions(-)
+
+--- a/arch/arm/boot/dts/bcm5301x.dtsi
++++ b/arch/arm/boot/dts/bcm5301x.dtsi
+@@ -8,6 +8,7 @@
+  * Licensed under the GNU/GPL. See COPYING for details.
+  */
++#include <dt-bindings/clock/bcm-nsp.h>
+ #include <dt-bindings/gpio/gpio.h>
+ #include <dt-bindings/input/input.h>
+ #include <dt-bindings/interrupt-controller/irq.h>
+@@ -27,7 +28,7 @@
+                       compatible = "ns16550";
+                       reg = <0x0300 0x100>;
+                       interrupts = <GIC_SPI 85 IRQ_TYPE_LEVEL_HIGH>;
+-                      clock-frequency = <100000000>;
++                      clocks = <&iprocslow>;
+                       status = "disabled";
+               };
+@@ -35,48 +36,55 @@
+                       compatible = "ns16550";
+                       reg = <0x0400 0x100>;
+                       interrupts = <GIC_SPI 85 IRQ_TYPE_LEVEL_HIGH>;
+-                      clock-frequency = <100000000>;
++                      clocks = <&iprocslow>;
+                       status = "disabled";
+               };
+       };
+       mpcore {
+               compatible = "simple-bus";
+-              ranges = <0x00000000 0x19020000 0x00003000>;
++              ranges = <0x00000000 0x19000000 0x00023000>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+-              scu@0000 {
++              a9pll: arm_clk@00000 {
++                      #clock-cells = <0>;
++                      compatible = "brcm,nsp-armpll";
++                      clocks = <&osc>;
++                      reg = <0x00000 0x1000>;
++              };
++
++              scu@20000 {
+                       compatible = "arm,cortex-a9-scu";
+-                      reg = <0x0000 0x100>;
++                      reg = <0x20000 0x100>;
+               };
+-              timer@0200 {
++              timer@20200 {
+                       compatible = "arm,cortex-a9-global-timer";
+-                      reg = <0x0200 0x100>;
++                      reg = <0x20200 0x100>;
+                       interrupts = <GIC_PPI 11 IRQ_TYPE_LEVEL_HIGH>;
+-                      clocks = <&clk_periph>;
++                      clocks = <&periph_clk>;
+               };
+-              local-timer@0600 {
++              local-timer@20600 {
+                       compatible = "arm,cortex-a9-twd-timer";
+-                      reg = <0x0600 0x100>;
++                      reg = <0x20600 0x100>;
+                       interrupts = <GIC_PPI 13 IRQ_TYPE_LEVEL_HIGH>;
+-                      clocks = <&clk_periph>;
++                      clocks = <&periph_clk>;
+               };
+-              gic: interrupt-controller@1000 {
++              gic: interrupt-controller@21000 {
+                       compatible = "arm,cortex-a9-gic";
+                       #interrupt-cells = <3>;
+                       #address-cells = <0>;
+                       interrupt-controller;
+-                      reg = <0x1000 0x1000>,
+-                            <0x0100 0x100>;
++                      reg = <0x21000 0x1000>,
++                            <0x20100 0x100>;
+               };
+-              L2: cache-controller@2000 {
++              L2: cache-controller@22000 {
+                       compatible = "arm,pl310-cache";
+-                      reg = <0x2000 0x1000>;
++                      reg = <0x22000 0x1000>;
+                       cache-unified;
+                       arm,shared-override;
+                       prefetch-data = <1>;
+@@ -94,14 +102,37 @@
+       clocks {
+               #address-cells = <1>;
+-              #size-cells = <0>;
++              #size-cells = <1>;
++              ranges;
+-              /* As long as we do not have a real clock driver us this
+-               * fixed clock */
+-              clk_periph: periph {
++              osc: oscillator {
++                      #clock-cells = <0>;
+                       compatible = "fixed-clock";
++                      clock-frequency = <25000000>;
++              };
++
++              iprocmed: iprocmed {
++                      #clock-cells = <0>;
++                      compatible = "fixed-factor-clock";
++                      clocks = <&genpll BCM_NSP_GENPLL_IPROCFAST_CLK>;
++                      clock-div = <2>;
++                      clock-mult = <1>;
++              };
++
++              iprocslow: iprocslow {
++                      #clock-cells = <0>;
++                      compatible = "fixed-factor-clock";
++                      clocks = <&genpll BCM_NSP_GENPLL_IPROCFAST_CLK>;
++                      clock-div = <4>;
++                      clock-mult = <1>;
++              };
++
++              periph_clk: periph_clk {
+                       #clock-cells = <0>;
+-                      clock-frequency = <400000000>;
++                      compatible = "fixed-factor-clock";
++                      clocks = <&a9pll>;
++                      clock-div = <2>;
++                      clock-mult = <1>;
+               };
+       };
+@@ -178,6 +209,25 @@
+               };
+       };
++      lcpll0: lcpll0@1800c100 {
++              #clock-cells = <1>;
++              compatible = "brcm,nsp-lcpll0";
++              reg = <0x1800c100 0x14>;
++              clocks = <&osc>;
++              clock-output-names = "lcpll0", "pcie_phy", "sdio",
++                                   "ddr_phy";
++      };
++
++      genpll: genpll@1800c140 {
++              #clock-cells = <1>;
++              compatible = "brcm,nsp-genpll";
++              reg = <0x1800c140 0x24>;
++              clocks = <&osc>;
++              clock-output-names = "genpll", "phy", "ethernetclk",
++                                   "usbclk", "iprocfast", "sata1",
++                                   "sata2";
++      };
++
+       nand: nand@18028000 {
+               compatible = "brcm,nand-iproc", "brcm,brcmnand-v6.1", "brcm,brcmnand";
+               reg = <0x18028000 0x600>, <0x1811a408 0x600>, <0x18028f00 0x20>;
diff --git a/target/linux/bcm53xx/patches-4.4/050-ARM-dts-enable-clock-support-for-BCM5301X.patch b/target/linux/bcm53xx/patches-4.4/050-ARM-dts-enable-clock-support-for-BCM5301X.patch
deleted file mode 100644 (file)
index a9a5246..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-From e96ef422d0095fe9ae39b03c0805a0db8ff7e382 Mon Sep 17 00:00:00 2001
-From: Jon Mason <jonmason@broadcom.com>
-Date: Tue, 13 Oct 2015 17:22:25 -0400
-Subject: [PATCH 50/50] ARM: dts: enable clock support for BCM5301X
-
-Replace current device tree dummy clocks with real clock support for
-Broadcom Northstar SoCs.
-
-Signed-off-by: Jon Mason <jonmason@broadcom.com>
----
- arch/arm/boot/dts/bcm5301x.dtsi | 88 ++++++++++++++++++++++++++++++++---------
- 1 file changed, 69 insertions(+), 19 deletions(-)
-
---- a/arch/arm/boot/dts/bcm5301x.dtsi
-+++ b/arch/arm/boot/dts/bcm5301x.dtsi
-@@ -8,6 +8,7 @@
-  * Licensed under the GNU/GPL. See COPYING for details.
-  */
-+#include <dt-bindings/clock/bcm-nsp.h>
- #include <dt-bindings/gpio/gpio.h>
- #include <dt-bindings/input/input.h>
- #include <dt-bindings/interrupt-controller/irq.h>
-@@ -42,41 +43,48 @@
-       mpcore {
-               compatible = "simple-bus";
--              ranges = <0x00000000 0x19020000 0x00003000>;
-+              ranges = <0x00000000 0x19000000 0x00023000>;
-               #address-cells = <1>;
-               #size-cells = <1>;
--              scu@0000 {
-+              a9pll: arm_clk@00000 {
-+                      #clock-cells = <0>;
-+                      compatible = "brcm,nsp-armpll";
-+                      clocks = <&osc>;
-+                      reg = <0x00000 0x1000>;
-+              };
-+
-+              scu@20000 {
-                       compatible = "arm,cortex-a9-scu";
--                      reg = <0x0000 0x100>;
-+                      reg = <0x20000 0x100>;
-               };
--              timer@0200 {
-+              timer@20200 {
-                       compatible = "arm,cortex-a9-global-timer";
--                      reg = <0x0200 0x100>;
-+                      reg = <0x20200 0x100>;
-                       interrupts = <GIC_PPI 11 IRQ_TYPE_LEVEL_HIGH>;
--                      clocks = <&clk_periph>;
-+                      clocks = <&periph_clk>;
-               };
--              local-timer@0600 {
-+              local-timer@20600 {
-                       compatible = "arm,cortex-a9-twd-timer";
--                      reg = <0x0600 0x100>;
-+                      reg = <0x20600 0x100>;
-                       interrupts = <GIC_PPI 13 IRQ_TYPE_LEVEL_HIGH>;
--                      clocks = <&clk_periph>;
-+                      clocks = <&periph_clk>;
-               };
--              gic: interrupt-controller@1000 {
-+              gic: interrupt-controller@21000 {
-                       compatible = "arm,cortex-a9-gic";
-                       #interrupt-cells = <3>;
-                       #address-cells = <0>;
-                       interrupt-controller;
--                      reg = <0x1000 0x1000>,
--                            <0x0100 0x100>;
-+                      reg = <0x21000 0x1000>,
-+                            <0x20100 0x100>;
-               };
--              L2: cache-controller@2000 {
-+              L2: cache-controller@22000 {
-                       compatible = "arm,pl310-cache";
--                      reg = <0x2000 0x1000>;
-+                      reg = <0x22000 0x1000>;
-                       cache-unified;
-                       arm,shared-override;
-                       prefetch-data = <1>;
-@@ -94,14 +102,37 @@
-       clocks {
-               #address-cells = <1>;
--              #size-cells = <0>;
-+              #size-cells = <1>;
-+              ranges;
--              /* As long as we do not have a real clock driver us this
--               * fixed clock */
--              clk_periph: periph {
-+              osc: oscillator {
-+                      #clock-cells = <0>;
-                       compatible = "fixed-clock";
-+                      clock-frequency = <25000000>;
-+              };
-+
-+              iprocmed: iprocmed {
-                       #clock-cells = <0>;
--                      clock-frequency = <400000000>;
-+                      compatible = "fixed-factor-clock";
-+                      clocks = <&genpll BCM_NSP_GENPLL_IPROCFAST_CLK>;
-+                      clock-div = <2>;
-+                      clock-mult = <1>;
-+              };
-+
-+              iprocslow: iprocslow {
-+                      #clock-cells = <0>;
-+                      compatible = "fixed-factor-clock";
-+                      clocks = <&genpll BCM_NSP_GENPLL_IPROCFAST_CLK>;
-+                      clock-div = <4>;
-+                      clock-mult = <1>;
-+              };
-+
-+              periph_clk: periph_clk {
-+                      #clock-cells = <0>;
-+                      compatible = "fixed-factor-clock";
-+                      clocks = <&a9pll>;
-+                      clock-div = <2>;
-+                      clock-mult = <1>;
-               };
-       };
-@@ -189,4 +220,23 @@
-               brcm,nand-has-wp;
-       };
-+
-+      lcpll0: lcpll0@1800c100 {
-+              #clock-cells = <1>;
-+              compatible = "brcm,nsp-lcpll0";
-+              reg = <0x1800c100 0x14>;
-+              clocks = <&osc>;
-+              clock-output-names = "lcpll0", "pcie_phy", "sdio",
-+                                   "ddr_phy";
-+      };
-+
-+      genpll: genpll@1800c140 {
-+              #clock-cells = <1>;
-+              compatible = "brcm,nsp-genpll";
-+              reg = <0x1800c140 0x24>;
-+              clocks = <&osc>;
-+              clock-output-names = "genpll", "phy", "ethernetclk",
-+                                   "usbclk", "iprocfast", "sata1",
-+                                   "sata2";
-+      };
- };
diff --git a/target/linux/bcm53xx/patches-4.4/083-ARM-dts-bcm5301x-Add-BCM-SVK-DT-files.patch b/target/linux/bcm53xx/patches-4.4/083-ARM-dts-bcm5301x-Add-BCM-SVK-DT-files.patch
deleted file mode 100644 (file)
index cd22e19..0000000
+++ /dev/null
@@ -1,218 +0,0 @@
-From a0aef7fbab0d8b5a0d445c74990e5233beda246e Mon Sep 17 00:00:00 2001
-From: Jon Mason <jonmason@broadcom.com>
-Date: Wed, 21 Oct 2015 18:46:04 -0400
-Subject: [PATCH] ARM: dts: bcm5301x: Add BCM SVK DT files
-
-Add device tree files for Broadcom Northstar based SVKs.  Since the
-bcm5301x.dtsi already exists, all that is necessary is the dts files to
-enable the UARTs.  With these files, the SVKs are able to boot to shell.
-
-Signed-off-by: Jon Mason <jonmason@broadcom.com>
----
- arch/arm/boot/dts/Makefile       |  5 +++-
- arch/arm/boot/dts/bcm94708.dts   | 56 +++++++++++++++++++++++++++++++++++
- arch/arm/boot/dts/bcm94709.dts   | 56 +++++++++++++++++++++++++++++++++++
- arch/arm/boot/dts/bcm953012k.dts | 63 ++++++++++++++++++++++++++++++++++++++++
- 4 files changed, 179 insertions(+), 1 deletion(-)
- create mode 100644 arch/arm/boot/dts/bcm94708.dts
- create mode 100644 arch/arm/boot/dts/bcm94709.dts
- create mode 100644 arch/arm/boot/dts/bcm953012k.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -75,7 +75,10 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
-       bcm4709-asus-rt-ac87u.dtb \
-       bcm4709-buffalo-wxr-1900dhp.dtb \
-       bcm4709-netgear-r7000.dtb \
--      bcm4709-netgear-r8000.dtb
-+      bcm4709-netgear-r8000.dtb \
-+      bcm94708.dtb \
-+      bcm94709.dtb \
-+      bcm953012k.dtb
- dtb-$(CONFIG_ARCH_BCM_63XX) += \
-       bcm963138dvt.dtb
- dtb-$(CONFIG_ARCH_BCM_CYGNUS) += \
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm94708.dts
-@@ -0,0 +1,56 @@
-+/*
-+ *  BSD LICENSE
-+ *
-+ *  Copyright(c) 2015 Broadcom Corporation.  All rights reserved.
-+ *
-+ *  Redistribution and use in source and binary forms, with or without
-+ *  modification, are permitted provided that the following conditions
-+ *  are met:
-+ *
-+ *    * Redistributions of source code must retain the above copyright
-+ *      notice, this list of conditions and the following disclaimer.
-+ *    * Redistributions in binary form must reproduce the above copyright
-+ *      notice, this list of conditions and the following disclaimer in
-+ *      the documentation and/or other materials provided with the
-+ *      distribution.
-+ *    * Neither the name of Broadcom Corporation nor the names of its
-+ *      contributors may be used to endorse or promote products derived
-+ *      from this software without specific prior written permission.
-+ *
-+ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-+ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-+ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-+ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-+ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-+ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-+ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-+ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-+ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-+ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-+ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm4708.dtsi"
-+
-+/ {
-+      model = "NorthStar SVK (BCM94708)";
-+      compatible = "brcm,bcm94708", "brcm,bcm4708";
-+
-+      aliases {
-+              serial0 = &uart0;
-+      };
-+
-+      chosen {
-+              stdout-path = "serial0:115200n8";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x08000000>;
-+      };
-+};
-+
-+&uart0 {
-+      status = "okay";
-+};
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm94709.dts
-@@ -0,0 +1,56 @@
-+/*
-+ *  BSD LICENSE
-+ *
-+ *  Copyright(c) 2015 Broadcom Corporation.  All rights reserved.
-+ *
-+ *  Redistribution and use in source and binary forms, with or without
-+ *  modification, are permitted provided that the following conditions
-+ *  are met:
-+ *
-+ *    * Redistributions of source code must retain the above copyright
-+ *      notice, this list of conditions and the following disclaimer.
-+ *    * Redistributions in binary form must reproduce the above copyright
-+ *      notice, this list of conditions and the following disclaimer in
-+ *      the documentation and/or other materials provided with the
-+ *      distribution.
-+ *    * Neither the name of Broadcom Corporation nor the names of its
-+ *      contributors may be used to endorse or promote products derived
-+ *      from this software without specific prior written permission.
-+ *
-+ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-+ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-+ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-+ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-+ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-+ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-+ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-+ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-+ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-+ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-+ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm4708.dtsi"
-+
-+/ {
-+      model = "NorthStar SVK (BCM94709)";
-+      compatible = "brcm,bcm94709", "brcm,bcm4709", "brcm,bcm4708";
-+
-+      aliases {
-+              serial0 = &uart0;
-+      };
-+
-+      chosen {
-+              stdout-path = "serial0:115200n8";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x08000000>;
-+      };
-+};
-+
-+&uart0 {
-+      status = "okay";
-+};
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm953012k.dts
-@@ -0,0 +1,63 @@
-+/*
-+ *  BSD LICENSE
-+ *
-+ *  Copyright(c) 2015 Broadcom Corporation.  All rights reserved.
-+ *
-+ *  Redistribution and use in source and binary forms, with or without
-+ *  modification, are permitted provided that the following conditions
-+ *  are met:
-+ *
-+ *    * Redistributions of source code must retain the above copyright
-+ *      notice, this list of conditions and the following disclaimer.
-+ *    * Redistributions in binary form must reproduce the above copyright
-+ *      notice, this list of conditions and the following disclaimer in
-+ *      the documentation and/or other materials provided with the
-+ *      distribution.
-+ *    * Neither the name of Broadcom Corporation nor the names of its
-+ *      contributors may be used to endorse or promote products derived
-+ *      from this software without specific prior written permission.
-+ *
-+ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-+ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-+ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-+ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-+ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-+ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-+ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-+ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-+ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-+ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-+ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm4708.dtsi"
-+
-+/ {
-+      model = "NorthStar SVK (BCM953012K)";
-+      compatible = "brcm,bcm953012k", "brcm,brcm53012", "brcm,bcm4708";
-+
-+      aliases {
-+              serial0 = &uart0;
-+              serial1 = &uart1;
-+      };
-+
-+      chosen {
-+              stdout-path = "serial0:115200n8";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x10000000>;
-+      };
-+};
-+
-+&uart0 {
-+      clock-frequency = <62499840>;
-+      status = "okay";
-+};
-+
-+&uart1 {
-+      clock-frequency = <62499840>;
-+      status = "okay";
-+};