config: Remove KERNEL_GIT_LOCAL_REPOSITORY option
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:45:16 +0000 (12:45 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:45:16 +0000 (12:45 +0000)
The GIT_LOCAL_REPOSITORY option adds the --reference argument to the
git clone kernel command line, if KERNEL_GIT_CLONE_URI is set.

This option is intended to speed-up the repo creation by using local
objets rather than downloading it. However, a local repo can be cloned
much faster by setting GIT_LOCAL_REPOSITORY directly to the local tree.

In that case, git clone will bypass the normal "git aware" transport
mechanism and clone the repository by copying and hardlinking objects
rather than downloading it, resulting in a significant speed increase.

That makes the GIT_LOCAL_REPOSITORY option pretty useless so we'll just
remove it and recommand the usage of KERNEL_GIT_CLONE_URI directly.

Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
SVN-Revision: 40944

config/Config-devel.in
include/kernel-defaults.mk

index 5e5c857b42678eaccc798ad9f8bbc530f6f5c0e7..fd57bcbccd2773026da577b0abc683bbdc989634 100644 (file)
@@ -62,14 +62,6 @@ menuconfig DEVEL
                  This will create a git clone of the kernel in your build
                  directory.
 
-       config KERNEL_GIT_LOCAL_REPOSITORY
-               string "Enter path to local reference repository" if DEVEL
-               default ""
-               help
-                 Enter a full pathname to a local reference git repository.
-                 In this instance, the --refererence option of git clone will
-                 be used thus creating a quick local clone of your repo.
-
        config BUILD_LOG
                bool "Enable log files during build process" if DEVEL
                help
index 322aeed5fa0607f2b9cf0d58d1b976097118c426..499ecdf3d80bb6bd0e69f6814ad635e8469a3faf 100644 (file)
@@ -40,15 +40,9 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
        touch $(LINUX_DIR)/.quilt_used
     endef
   else
-    ifeq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
-      define Kernel/Prepare/Default
+    define Kernel/Prepare/Default
        git clone $(CONFIG_KERNEL_GIT_CLONE_URI) $(LINUX_DIR)
-      endef
-    else
-      define Kernel/Prepare/Default
-       git clone --reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY) $(CONFIG_KERNEL_GIT_CLONE_URI) $(LINUX_DIR)
-      endef
-    endif
+    endef
   endif
 else
   define Kernel/Prepare/Default