ramips: add support for Sparklan WCR-150GN board
authorGabor Juhos <juhosg@openwrt.org>
Sun, 15 Aug 2010 09:43:07 +0000 (09:43 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 15 Aug 2010 09:43:07 +0000 (09:43 +0000)
This patch adds support for Sparklan WCR-150GN board.
Network configuration should be tweaked to make it work fully. The
reason it's not in this patch is that ramips target should be modified
to support different /etc/config/network files for different boards.

Signed-off-by: Roman Yeryomin <roman@advem.lv>
SVN-Revision: 22658

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wcr150gn.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.32
target/linux/ramips/rt305x/config-2.6.34

index 22e2b6462792801b2d2a5b909662bf784ebbf486..53d42a04eb25af4c5604692827940b8394236133 100644 (file)
@@ -21,6 +21,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_DIR_300_REVB,       /* D-Link DIR-300 rev B */
 
        /* RT3052 based machines */
        RAMIPS_MACH_DIR_300_REVB,       /* D-Link DIR-300 rev B */
 
        /* RT3052 based machines */
+       RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
        RAMIPS_MACH_WHR_G300N,          /* Buffalo WHR-G300N */
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
        RAMIPS_MACH_WHR_G300N,          /* Buffalo WHR-G300N */
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
index 532e471d77b9afb4b451cc2e0a512adf128724d1..e43261ed392b57562bef5eb5dbde370f805e9070 100644 (file)
@@ -20,6 +20,12 @@ config RT305X_MACH_V22RW_2X2
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_WCR150GN
+       bool "Sparklan WCR-150GN support"
+       default y
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_FONERA20N
        bool "La Fonera20N board support"
        default y
 config RT305X_MACH_FONERA20N
        bool "La Fonera20N board support"
        default y
index a1278c3057bb8ca1ef514e27ab63c6c4978f3fcb..28cb88c6300017d5425d05f1047ec96ad3360ca1 100644 (file)
@@ -13,5 +13,6 @@ obj-$(CONFIG_EARLY_PRINTK)            += early_printk.o
 
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
+obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wcr150gn.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wcr150gn.c
new file mode 100644 (file)
index 0000000..3c3319b
--- /dev/null
@@ -0,0 +1,68 @@
+/*
+ *  Sparklan WCR-150GN board support
+ *
+ *  Copyright (C) 2010 Roman Yeryomin <roman@advem.lv>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition wcr150gn_partitions[] = {
+       {
+               .name   = "Bootloader",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "Config",
+               .offset = 0x030000,
+               .size   = 0x040000,
+       }, {
+               .name   = "Factory",
+               .offset = 0x040000,
+               .size   = 0x050000,
+       }, {
+               .name   = "Kernel",
+               .offset = 0x050000,
+               .size   = 0x120000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x120000,
+               .size   = 0x400000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data wcr150gn_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(wcr150gn_partitions),
+       .parts          = wcr150gn_partitions,
+#endif
+};
+
+static void __init wcr150gn_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+       rt305x_register_flash(0, &wcr150gn_flash_data);
+       rt305x_register_ethernet();
+       rt305x_register_wifi();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_WCR150GN, "WCR150GN", "Sparklan WCR-150GN",
+            wcr150gn_init);
index 1addcbf22f13b57acc7ed19bb910129d8beea585..03be7647ce4550cc8b69f2904b2bf1a1fa7a695c 100644 (file)
@@ -96,12 +96,26 @@ define Image/Build/Profile/WHRG300N
        $(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
 endef
 
        $(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
 endef
 
+
+mtdlayout_wcr150gn=mtdparts=physmap-flash.0:192k(Bootloader)ro,64k(Config),64k(Factory),832k(Kernel),2944k(rootfs),3776k@0x50000(firmware)
+mtd_wcr150gn_kernel_part_size=851968
+mtd_wcr150gn_rootfs_part_size=3014656
+define Image/Build/Template/WCR150GN
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wcr150gn,$(mtd_wcr150gn_kernel_part_size),$(mtd_wcr150gn_rootfs_part_size))
+endef
+
+define Image/Build/Profile/WCR150GN
+       $(call Image/Build/Template/WCR150GN,$(1),wcr150gn,WCR150GN)
+endef
+
+
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
+       $(call Image/Build/Profile/WCR150GN,$(1))
 endef
 endif
 
 endef
 endif
 
index 9e8030aaacee9cdafe92f48cf55f95690fcf457e..c7ec7758948b4041be357b7805076c59ebbcc77b 100644 (file)
@@ -119,6 +119,7 @@ CONFIG_RALINK_RT305X=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
+CONFIG_RT305X_MACH_WCR150GN=y
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set
index 513224a3cde715a54f5695fbe7aa705e3899d2e8..a493b5be1883a386778797d4ae76795b42b3eb8f 100644 (file)
@@ -129,6 +129,7 @@ CONFIG_RALINK_RT305X=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
+CONFIG_RT305X_MACH_WCR150GN=y
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set