libnfnetlink: quote $(FPIC) on command line
authorPhilip Prindeville <philipp@redfish-solutions.com>
Fri, 19 Mar 2021 23:09:26 +0000 (17:09 -0600)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 12 Apr 2021 18:45:29 +0000 (20:45 +0200)
When $(FPIC) gets expanded on the command line (for instance
when setting environment variables for libtool, configure, or
make) we can't count on it not needing quoting (i.e. it could
contain multiple flags separated with spaces).

Fixes: dc31191ec3e5 ("build: make sure asm gets built with -DPIC")
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
(cherry picked from commit 7fae64cc065738b73a1dddc2fc28adde36c1ae3d)

package/libs/libnfnetlink/Makefile

index 7d65d6385784e3d418f714386efe505b905c3b3e..bc64ff111d1f37e64463d519736d013679ccebf0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnfnetlink
 PKG_VERSION:=1.0.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
@@ -45,7 +45,7 @@ CONFIGURE_ARGS += \
        --enable-shared
 
 CONFIGURE_VARS += \
-       lt_prog_compiler_pic=$(FPIC)
+       lt_prog_compiler_pic="$(FPIC)"
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/libnfnetlink