bcm53xx: switch RT-N18U firmware to the UBI
authorRafał Miłecki <zajec5@gmail.com>
Mon, 20 Oct 2014 22:09:40 +0000 (22:09 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Mon, 20 Oct 2014 22:09:40 +0000 (22:09 +0000)
According to the ticket #18152 it also uses NAND with 0x20000 erase size
and 0x800 page size.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 43008

target/linux/bcm53xx/image/Makefile

index 09109e2d2c6142da52588790d040633ca2c3f6e1..b2fafd9d3db34097c9d792d21d2ff8a35e2d1f55 100644 (file)
@@ -81,7 +81,7 @@ endef
 define Image/Build
        ( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
 
-       $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,serial,RT-N18U)
+       $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,nand-0x20000-0x800,RT-N18U)
 
        $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,nand-0x20000-0x800,U12H245T00_NETGEAR,1)
        $(call Image/Build/Chk,$(1),bcm4708-netgear-r6300-v2,nand-0x20000-0x800,U12H240T00_NETGEAR,1)