bcm963xx: fix load address / kernel entry
authorFelix Fietkau <nbd@openwrt.org>
Sun, 18 May 2008 17:29:39 +0000 (17:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 18 May 2008 17:29:39 +0000 (17:29 +0000)
Current kernels have the same kernel entry as load address, so just set them
like this. Also, the BCM963xx uses 0x80010000 as its load address, so use this
too.

Signed-off-by: Axel Gembe <ago@bastart.eu.org>
SVN-Revision: 11169

target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/image/lzma-loader/src/Makefile

index 16c57cae4fc4df3b870c94af6fb43f56916303df..227dbd7a5469f271574c116083752ec2354db053 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-LOADADDR = 0x8108c8f4          # RAM start + 16M 
-KERNEL_ENTRY = 0x80100000      # Default kernel entry in arch/mips/Makefile
+LOADADDR = 0x80010000          # RAM start + 16M 
+KERNEL_ENTRY = $(LOADADDR)     # Newer kernels add a jmp to the kernel_entry at the start of the binary
 RAMSIZE = 0x01000000           # 64MB
 
 LOADER_MAKEOPTS= \
index 85a864674bab2ed058d68433a1306752acf5e364..83e2c52386252c2426a7b91c1f15dba2592fb7e2 100644 (file)
@@ -17,7 +17,7 @@
 #   Cleaned up, modified for lzma support, removed from kernel
 #
 
-TEXT_START     := 0x80001000
+TEXT_START     := 0x80010000
 BZ_TEXT_START  := 0x80300000
 
 OBJCOPY                := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S