brcm63xx: Add DT support for 96368MVNgr
authorJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:25:57 +0000 (12:25 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:25:57 +0000 (12:25 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42737

32 files changed:
target/linux/brcm63xx/dts/bcm96368MVNgr.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/01-generic.mk

diff --git a/target/linux/brcm63xx/dts/bcm96368MVNgr.dts b/target/linux/brcm63xx/dts/bcm96368MVNgr.dts
new file mode 100644 (file)
index 0000000..b274bfd
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6368.dtsi"
+
+/ {
+       model = "Broadcom BCM96368MVNgr reference board";
+       compatible = "brcm,bcm96368mvngr", "brcm,bcm6368";
+};
index 27d0c0a2e3c9f0fc554bbbd9b9b9419595021130..63528ddcb2005f63eb9d1bf5a8e4d9d264cca2ac 100755 (executable)
@@ -234,7 +234,6 @@ endef
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
        # Various routers
-       $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
        $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
 
        # BT Voyager V210_BTR
@@ -350,6 +349,8 @@ $(eval $(call CfeImageDTB,96348R,bcm96348R,96348R,6348,96348R-generic))
 $(eval $(call CfeImageDTB,96358VW,bcm96358VW,96358VW,6358,96358VW-generic))
 # Generic 96358VW2
 $(eval $(call CfeImageDTB,96358VW2,bcm96358VW2,96358VW2,6358,96358VW2-generic))
+# Generic 96368MVNgr
+$(eval $(call CfeImageDTB,96368MVNgr,bcm96368MVNgr,96368MVNgr,6368,96368MVNgr-generic))
 
 # ADB P.DG A4001N
 $(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
index fadf2ebf3114c5b53dd01407eb8095c928e60da4..720ea6d1ade4d45042573409194004dbebd38ca5 100644 (file)
@@ -9,13 +9,14 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2012,6 +2012,72 @@ static struct board_info __initdata boar
+@@ -2012,6 +2012,73 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
 +
 +static struct board_info __initdata board_96368mvngr = {
 +      .name                           = "96368MVNgr",
++      .of_board_id                    = "brcm,bcm96368mvngr",
 +      .expected_cpu_id                = 0x6368,
 +
 +      .has_uart0                      = 1,
@@ -82,7 +83,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2069,6 +2135,7 @@ static const struct board_info __initcon
+@@ -2069,6 +2136,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
index 46d52302dba761dae3460a428bdbc8052b0fadc7..ec7b95bbe268b4e061c7c3342a4aae0cedaca807 100644 (file)
@@ -87,7 +87,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2121,6 +2192,7 @@ static const struct board_info __initcon
+@@ -2122,6 +2193,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index d7a45ca5b79a20597ab4ab1fd9f8cb35e055a2ca..e14663d24da39556e33b8292737597f1e7985dac 100644 (file)
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2193,6 +2298,7 @@ static const struct board_info __initcon
+@@ -2194,6 +2299,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 779582b0ad9b188a76a71154d1bd2003e53648f0..0ed9f532f2c3333294bf91391b2b236281b76b4b 100644 (file)
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
-@@ -2328,6 +2381,7 @@ static const struct board_info __initcon
+@@ -2329,6 +2382,7 @@ static const struct board_info __initcon
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
index f0b80743aef53aa074e263760fbd280fe2f98ea8..00b00aa4641fa861b3ad831267395210a9506ca4 100644 (file)
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
-@@ -2393,6 +2518,7 @@ static const struct board_info __initcon
+@@ -2394,6 +2519,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index 20b8db41bae3c6542c37db43272d7e09511902f4..a71be36ecf056370aedfcceef320b9a51de99849 100644 (file)
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2521,6 +2589,7 @@ static const struct board_info __initcon
+@@ -2522,6 +2590,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 701ff35beb5d0434d6860fb4bf265f4e3d9d4c7a..26ad63c1fcde0be9ddf23d3fdec0b8e7ff76eb83 100644 (file)
  /*
   * known 6368 boards
   */
-@@ -2592,6 +2694,10 @@ static const struct board_info __initcon
+@@ -2593,6 +2695,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
index 9dac9d5d3f926a263d1b9e59e1d603166181986d..55a01c9101d5e4864b691f00e812407258e1bfa5 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2665,6 +2716,7 @@ static const struct board_info __initcon
+@@ -2666,6 +2717,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index 36a9dab0ee0924e9d7ff40c9dd74704f819dded6..f56b677c7491073e211f7b08f57ffccf7460d9ad 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2697,6 +2825,7 @@ static const struct board_info __initcon
+@@ -2698,6 +2826,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 1efd27c7901ef29579434ef55263129e39b70214..07af3cc0e1bf70644674c3071fa03d70e9bb8ac2 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .of_board_id                    = "brcm,bcm963281TAN",
-@@ -2824,6 +2934,7 @@ static const struct board_info __initcon
+@@ -2825,6 +2935,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 6f6989fdd2486844ac9fdc5023ea2a12f7731cfb..134114ec4bef6d14e656ec472e3ea2e9dc2e1dda 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2934,6 +3020,7 @@ static const struct board_info __initcon
+@@ -2935,6 +3021,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 141123659580ce4cfe68abf8251213f736f6ab46..504598e783afb9a8f1cf9c35c951bd1b6db559a9 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3034,6 +3083,7 @@ static const struct board_info __initcon
+@@ -3035,6 +3084,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index d603287589fdc38fd95d703e284675f02f82c516..aefe4074d29a037ca44d59a5065bbd92a5803a27 100644 (file)
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3119,6 +3519,9 @@ static const struct board_info __initcon
+@@ -3120,6 +3520,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 6bfa999655949a6d708e50b1a97055644c07756f..a66a53606a2c934299ee9f1a9fed702c121f6a43 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3484,6 +3538,7 @@ static const struct board_info __initcon
+@@ -3485,6 +3539,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index 9fcab618d4f48df37e83e2277725ca624852b920..e8fba3176a7da9a04c6556ba962ab264ae335cad 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3528,6 +3644,7 @@ static const struct board_info __initcon
+@@ -3529,6 +3645,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index 31b2b9216614b869dc237fa0b042a865444c6a2b..cb65d697cc911cb80c454f3f0e301f142798165f 100644 (file)
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3700,6 +3790,7 @@ static const struct board_info __initcon
+@@ -3701,6 +3791,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index ed857c33bf9ba039aeebbc6847c26c644fefa9df..dc904eb3fee035d8b72f98256b42424e8278fe38 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3958,6 +4045,9 @@ static const struct board_info __initcon
+@@ -3959,6 +4046,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 0b88dd0e9f377d26e78c282ae979c67c4a193098..6bb1a63a8ddd21bbb6b5b6f41b2c3f116f0cbf93 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4047,6 +4135,7 @@ static const struct board_info __initcon
+@@ -4048,6 +4136,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index a2b134063d80a606b2150e66ebb7b557a8cc5b78..7691f11d2c832debe7877f905f78200b7598d92c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4127,6 +4127,75 @@ static struct board_info __initdata boar
+@@ -4128,6 +4128,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4207,6 +4276,9 @@ static const struct board_info __initcon
+@@ -4208,6 +4277,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 71bc7e26f2c1c0c14423feae79d1a0bbc00df1fd..21feb6dc69e8d8c9b2f68fe1591ebbd6cabbf949 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4247,6 +4293,7 @@ static const struct board_info __initcon
+@@ -4248,6 +4294,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index dc7a724968af523674347eb9bf75b07f82b80c6c..1038b07192d8392a33ae9333c08f9921efa36d7a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4239,6 +4239,108 @@ static struct board_info __initdata boar
+@@ -4240,6 +4240,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4325,6 +4427,7 @@ static const struct board_info __initcon
+@@ -4326,6 +4428,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 21ea5eae2e7beacf05c689a91022fc9628d2d9da..b4e1c4997e27566a4f1e3bc7a814921842acc9d0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4176,6 +4176,131 @@ static struct board_info __initdata boar
+@@ -4177,6 +4177,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4426,6 +4551,7 @@ static const struct board_info __initcon
+@@ -4427,6 +4552,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 8700c99d62c24f87ab3bd781489ae7e609927e44..8566595049013a557f6001c135566bc857d353d3 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4170,6 +4171,118 @@ static struct board_info __initdata boar
+@@ -4171,6 +4172,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4549,6 +4662,7 @@ static const struct board_info __initcon
+@@ -4550,6 +4663,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index a40c41f427c3b8a83a1f84435c292091394b4aac..ce5a2d122f383e2d18eee8b2252405bbf52323e6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4172,6 +4172,117 @@ static struct board_info __initdata boar
+@@ -4173,6 +4173,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4662,6 +4773,7 @@ static const struct board_info __initcon
+@@ -4663,6 +4774,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 9b6457c689f21219cea9253976a5dfded729e7f7..c985bb61af339934885d6a7803c51b6de3adb143 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4283,6 +4283,117 @@ static struct board_info __initdata boar
+@@ -4284,6 +4284,117 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4774,6 +4885,7 @@ static const struct board_info __initcon
+@@ -4775,6 +4886,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 410e7e8e4e9ef10f6ff108508f39177e3939faa9..f219e42b93384b24577e1201a8158a8b7e79462c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4181,6 +4181,97 @@ static struct sprom_fixup __initdata vr3
+@@ -4182,6 +4182,97 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -98,7 +98,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4884,6 +4975,7 @@ static const struct board_info __initcon
+@@ -4885,6 +4976,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 09033ff2373f819ba85be83a7577f54783b39dfb..ebdd899b6b44aaa367926c8e59664bbddf68e86e 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
-@@ -4959,6 +5010,7 @@ static const struct board_info __initcon
+@@ -4960,6 +5011,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 877b1ead7fafe69a68a117948adad89e3d9ddd55..de4fd11275f84d08faae86868c9956b37149748d 100644 (file)
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .of_board_id                    = "adb,a4001n1",
-@@ -4961,6 +5051,7 @@ static const struct board_info __initcon
+@@ -4962,6 +5052,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 4fa6709446e5f38db0e172c7abf8b0e28995d9c9..7c7abeb51b9e155612c5d9f240877f8bccab99be 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5045,6 +5180,7 @@ static const struct board_info __initcon
+@@ -5046,6 +5181,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 685d108b22f99769421a91c25ab850fbf64ba69a..f190141a4123c5e42feb0b88accad15ce3127dc0 100644 (file)
@@ -103,3 +103,12 @@ define Profile/96358VW2/Description
   Package set optimized for 96358VW2.
 endef
 $(eval $(call Profile,96358VW2))
+
+define Profile/96368MVNgr
+  NAME:=Generic 96368MVNgr
+  PACKAGES:=
+endef
+define Profile/96368MVNgr/Description
+  Package set optimized for 96368MVNgr.
+endef
+$(eval $(call Profile,96368MVNgr))