tools: zstd: convert to make and drop meson dependency
authorChristian Marangi <ansuelsmth@gmail.com>
Tue, 2 Apr 2024 23:07:14 +0000 (01:07 +0200)
committerRobert Marko <robimarko@gmail.com>
Sat, 6 Apr 2024 09:24:18 +0000 (11:24 +0200)
Convert to make and drop meson dependency since it's not a core tools
and can't depend on advanced build system like cmake or meson.

On top of this make is the official build support and cmake/meson are
supported by 3rd parties.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
tools/Makefile
tools/zstd/Makefile

index 7607e844817f4971f334e4950f5ce93bc7dc42a5..36a2ae1933394dd3a6ddaa3f5f6ce8fc5188c73c 100644 (file)
@@ -130,7 +130,6 @@ $(curdir)/sdcc/compile := $(curdir)/bison/compile
 $(curdir)/squashfs3-lzma/compile := $(curdir)/lzma-old/compile
 $(curdir)/squashfs4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
 $(curdir)/util-linux/compile := $(curdir)/bison/compile
-$(curdir)/zstd/compile := $(curdir)/meson/compile
 
 ifneq ($(HOST_OS),Linux)
   $(curdir)/coreutils/compile += $(curdir)/automake/compile $(curdir)/bison/compile $(curdir)/gnulib/compile
index 41dd70b7a9d3cede54bf3ae0ac183f5d8699d298..3f69c6d497b2da352061af32156ddc2e27289f99 100644 (file)
@@ -11,25 +11,33 @@ PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:facebook:zstandard
 
-include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/meson.mk
+HOST_BUILD_PARALLEL:=1
 
-MESON_HOST_BUILD_DIR:=$(HOST_BUILD_DIR)/build/meson/openwrt-build
+include $(INCLUDE_DIR)/host-build.mk
 
 HOSTCC:= $(HOSTCC_NOCACHE)
 
-MESON_HOST_ARGS += \
-       -Ddefault_library=static \
-       -Dlegacy_level=7 \
-       -Ddebug_level=0 \
-       -Dbacktrace=disabled \
-       -Dstatic_runtime=false \
-       -Dbin_programs=true \
-       -Dbin_tests=false \
-       -Dbin_contrib=false \
-       -Dmulti_thread=enabled \
-       -Dzlib=disabled \
-       -Dlzma=disabled \
-       -Dlz4=disabled
+HOST_MAKE_FLAGS += \
+       ZSTD_LEGACY_SUPPORT=7 \
+       BACKTRACE=0 \
+       HAVE_THREAD=1 \
+       HAVE_ZLIB=0 \
+       HAVE_LZMA=0 \
+       HAVE_LZ4=0 \
+       PREFIX=$(HOST_BUILD_PREFIX)
+
+define Host/Compile
+       $(call Host/Compile/Default,lib-mt)
+       $(call Host/Compile/Default,zstd)
+endef
+
+define Host/Install
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib install-pc install-static PREFIX=$(HOST_BUILD_PREFIX)
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/programs install PREFIX=$(HOST_BUILD_PREFIX)
+endef
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
+endef
 
 $(eval $(call HostBuild))