kernel: bpf-headers: fix build error when testing kernel is used
authorAnsuel Smith <ansuelsmth@gmail.com>
Sat, 22 Jan 2022 20:27:49 +0000 (21:27 +0100)
committerPaul Spooren <mail@aparcar.org>
Sun, 6 Feb 2022 11:43:57 +0000 (12:43 +0100)
Now that we have separate files for each kernel version,
only the version/hash for the target kernel are available.
This cause a missing hash error (and wrong kernel version) for
bpf-headers when a testing kernel version is used for the current target.

Fix this error by manually including the kernel version/hash file for the
specific kernel version requested.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
package/kernel/bpf-headers/Makefile

index 0f0857133a872f19fd4bff2c7f90a551e5c39bd5..4d603707af59f58eae17b1bdb0fe34056e3c563a 100644 (file)
@@ -14,6 +14,9 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=linux
 PKG_PATCHVER:=5.10
+# Manually include kernel version and hash from kernel details file
+include $(INCLUDE_DIR)/kernel-$(PKG_PATCHVER)
+
 PKG_VERSION:=$(PKG_PATCHVER)$(strip $(LINUX_VERSION-$(PKG_PATCHVER)))
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=$(LINUX_SITE)