kernel: bump 5.4 to 5.4.87
authorJohn Audia <graysky@archlinux.us>
Wed, 6 Jan 2021 17:37:16 +0000 (12:37 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 8 Jan 2021 20:09:17 +0000 (21:09 +0100)
All modification by update_kernel.sh.

Build system: x86_64
Build-tested: ipq806x/R7800, bcm27xx/bcm2711
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Compile-tested [*]: ath79/{generic,tiny}, ipq40xx, octeon,
                    ramips/mt7621, realtek, x86/64.
Run-tested [*]:     ramips/mt7621 (DIR-878 A1, R6800, RT-AC57U),
                    octeon (EdgeRouter Lite).

Signed-off-by: John Audia <graysky@archlinux.us>
Tested-by: Stijn Segers <foss@volatilesystems.org> [*]
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0084-hci_h5-Don-t-send-conf_req-when-ACTIVE.patch
target/linux/generic/hack-5.4/204-module_strip.patch
target/linux/generic/pending-5.4/530-jffs2_make_lzma_available.patch
target/linux/ramips/patches-5.4/0003-MIPS-Fix-memory-reservation-in-bootmem_init-for-cert.patch
target/linux/ramips/patches-5.4/0013-owrt-hack-fix-mt7688-cache-issue.patch
target/linux/realtek/patches-5.4/705-add-rtl-phy.patch

index dcbc45823bf5f6e60f557d791fbd74a96ff38af2..4a2b9ae2f4df22574e9d1668badb3b5be222fbed 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .86
+LINUX_VERSION-5.4 = .87
 
-LINUX_KERNEL_HASH-5.4.86 = eb36b5fc6ef7b953acba0a3e62d872e0330c4d34b38d58f5714493a4fe3b0e8b
+LINUX_KERNEL_HASH-5.4.87 = 6a34e93e2e84bb645155124962307ad9d3646124f43838d087209ed4ea595c31
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index a800039f88843a7771b83a5639bfab385d96baeb..87240aa5d84a0fb933f8bf54360005be71c1a420 100644 (file)
@@ -11,7 +11,7 @@ other with conf_req and conf_rsp messages, in a demented game of tag.
 
 --- a/drivers/bluetooth/hci_h5.c
 +++ b/drivers/bluetooth/hci_h5.c
-@@ -342,7 +342,8 @@ static void h5_handle_internal_rx(struct
+@@ -346,7 +346,8 @@ static void h5_handle_internal_rx(struct
                h5_link_control(hu, conf_req, 3);
        } else if (memcmp(data, conf_req, 2) == 0) {
                h5_link_control(hu, conf_rsp, 2);
index f311b176f3a5b6c9bdecf609865ba075182972e7..2b4435f93edc554251c05bfd63d4a87c6c540f84 100644 (file)
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3127,9 +3127,11 @@ static int setup_load_info(struct load_i
+@@ -3125,9 +3125,11 @@ static int setup_load_info(struct load_i
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3150,6 +3152,7 @@ static int check_modinfo(struct module *
+@@ -3148,6 +3150,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
index eb0e51d57436a2d068d829cc0862fdcd2e144873..f4976885569911dd2f696fa038d1cd08315fbc8a 100644 (file)
@@ -244,7 +244,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
 +}
 --- a/fs/jffs2/super.c
 +++ b/fs/jffs2/super.c
-@@ -377,14 +377,41 @@ static int __init init_jffs2_fs(void)
+@@ -380,14 +380,41 @@ static int __init init_jffs2_fs(void)
        BUILD_BUG_ON(sizeof(struct jffs2_raw_inode) != 68);
        BUILD_BUG_ON(sizeof(struct jffs2_raw_summary) != 32);
  
index fa923f18296fe4b01c23abe38114a4955f6a7c2e..63429f49b0ba70bce30132ee96ca18a1a5509a29 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -285,6 +285,8 @@ static unsigned long __init init_initrd(
+@@ -287,6 +287,8 @@ static unsigned long __init init_initrd(
   * Initialize the bootmem allocator. It also setup initrd related data
   * if needed.
   */
@@ -25,7 +25,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
  #if defined(CONFIG_SGI_IP27) || (defined(CONFIG_CPU_LOONGSON3) && defined(CONFIG_NUMA))
  
  static void __init bootmem_init(void)
-@@ -323,7 +325,7 @@ static void __init bootmem_init(void)
+@@ -325,7 +327,7 @@ static void __init bootmem_init(void)
        /*
         * Reserve any memory between the start of RAM and PHYS_OFFSET
         */
@@ -34,7 +34,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
                memblock_reserve(PHYS_OFFSET, ramstart - PHYS_OFFSET);
  
        if (PFN_UP(ramstart) > ARCH_PFN_OFFSET) {
-@@ -384,8 +386,6 @@ static void __init bootmem_init(void)
+@@ -386,8 +388,6 @@ static void __init bootmem_init(void)
  
  #endif        /* CONFIG_SGI_IP27 */
  
index 6b1cc15158fe6817cfecf32776827f22b38a7831..bedea145061fa92220c63ff772d6c5e765874b38 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -652,8 +652,6 @@ static void __init arch_mem_init(char **
+@@ -723,8 +723,6 @@ static void __init arch_mem_init(char **
                memblock_reserve(crashk_res.start,
                                 crashk_res.end - crashk_res.start + 1);
  #endif
@@ -19,7 +19,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        /*
         * In order to reduce the possibility of kernel panic when failed to
         * get IO TLB memory under CONFIG_SWIOTLB, it is better to allocate
-@@ -770,6 +768,7 @@ void __init setup_arch(char **cmdline_p)
+@@ -841,6 +839,7 @@ void __init setup_arch(char **cmdline_p)
  
        cpu_cache_init();
        paging_init();
index ea0d48861d59f129fd1980ef4f1d534ed5a13736..f4cd8f2d6d7a68459370142c1ae88477632e93cb 100644 (file)
@@ -1,9 +1,9 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -454,6 +454,12 @@
+@@ -540,6 +540,12 @@ config REALTEK_PHY
        ---help---
          Supports the Realtek 821x PHY.
-
 +config REALTEK_SOC_PHY
 +      tristate "Realtek SoC PHYs"
 +      depends on RTL838X
@@ -15,7 +15,7 @@
        ---help---
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -87,6 +87,7 @@
+@@ -102,6 +102,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o