ar71xx: create firmware image for WP543 boards with 4/8/16MB of flash
authorGabor Juhos <juhosg@openwrt.org>
Mon, 19 Oct 2009 08:07:40 +0000 (08:07 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 19 Oct 2009 08:07:40 +0000 (08:07 +0000)
SVN-Revision: 18075

target/linux/ar71xx/image/Makefile

index 816f27e63a9ef774d5bba1df8434de0b2954235f..5a126c0af2061147f2257bb6cc780ab2fe758f5f 100644 (file)
@@ -106,9 +106,21 @@ endef
 
 define Image/Build/MyLoader
        -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) \
 
 define Image/Build/MyLoader
        -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) \
-               -p0x30000:0xc0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma  \
-               -p0xf0000:0:::rootfs:$(KDIR)/root.$(1) \
-               $(call imgname,$(1),$(2)).img
+               -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+               -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+               $(call imgname,$(1),$(2))-2M.img
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s 0x400000 \
+               -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+               -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+               $(call imgname,$(1),$(2))-4M.img
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s 0x800000 \
+               -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+               -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+               $(call imgname,$(1),$(2))-8M.img
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s 0x1000000 \
+               -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+               -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+               $(call imgname,$(1),$(2))-16M.img
 endef
 
 define Image/Build/UBNT
 endef
 
 define Image/Build/UBNT