ath79: support for TP-Link EAP225-Outdoor v1
authorSander Vanheule <sander@svanheule.net>
Tue, 7 Jul 2020 16:04:37 +0000 (18:04 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 23 Nov 2020 21:53:15 +0000 (22:53 +0100)
TP-Link EAP225-Outdoor v1 is an AC1200 (802.11ac Wave-2) pole or wall
mount access point. Debricking requires access to the serial port, which
is non-trivial.

Device specifications:
* SoC: QCA9563 @ 775MHz
* Memory: 128MiB DDR2
* Flash: 16MiB SPI-NOR
* Wireless 2.4GHz (SoC): b/g/n 2x2
* Wireless 5GHz (QCA9886): a/n/ac 2x2 MU-MIMO
* Ethernet (AR8033): 1× 1GbE, PoE

Flashing instructions:
* ssh into target device with recent (>= v1.6.0) firmware
* run `cliclientd stopcs` on target device
* upload factory image via web interface

Debricking:
To recover the device, you need access to the serial port. This requires
fine soldering to test points, or the use of probe pins.
* Open the case and solder wires to the test points: RXD, TXD and TPGND4
  * Use a 3.3V UART, 115200 baud, 8n1
* Interrupt bootloader by holding ctrl+B during boot
* upload initramfs via built-in tftp client and perform sysupgrade
    setenv ipaddr 192.168.1.1 # default, change as required
    setenv serverip 192.168.1.10 # default, change as required
    tftp 0x80800000 initramfs.bin
    bootelf $fileaddr

MAC addresses:
MAC address (as on device label) is stored in device info partition at
an offset of 8 bytes. ath9k device has same address as ethernet, ath10k
uses address incremented by 1.
From stock ifconfig:

    ath0      Link encap:Ethernet  HWaddr D8:...:2E
    ath10     Link encap:Ethernet  HWaddr D8:...:2F
    br0       Link encap:Ethernet  HWaddr D8:...:2E
    eth0      Link encap:Ethernet  HWaddr D8:...:2E

Tested by forum user PolynomialDivision on firmware v1.7.0.
UART access tested by forum user arinc9.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/ath79/dts/qca9563_tplink_eap225-outdoor-v1.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

diff --git a/target/linux/ath79/dts/qca9563_tplink_eap225-outdoor-v1.dts b/target/linux/ath79/dts/qca9563_tplink_eap225-outdoor-v1.dts
new file mode 100644 (file)
index 0000000..fc6d336
--- /dev/null
@@ -0,0 +1,30 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9563_tplink_eap2x5-1port.dtsi"
+
+/ {
+       compatible = "tplink,eap225-outdoor-v1", "qca,qca9563";
+       model = "TP-Link EAP225-Outdoor v1";
+
+       aliases {
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_amber;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_amber;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_green: status_green {
+                       label = "green:status";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               led_status_amber: status_amber {
+                       label = "amber:status";
+                       gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
index c29c4006c80a20ea970301ef40002994c858915e..928b6c8903edd717cbdbd9ca8125d0d598cbb216 100755 (executable)
@@ -48,6 +48,7 @@ ath79_setup_interfaces()
        tplink,cpe510-v3|\
        tplink,cpe610-v1|\
        tplink,cpe610-v2|\
        tplink,cpe510-v3|\
        tplink,cpe610-v1|\
        tplink,cpe610-v2|\
+       tplink,eap225-outdoor-v1|\
        tplink,eap245-v1|\
        tplink,re350k-v1|\
        tplink,re355-v1|\
        tplink,eap245-v1|\
        tplink,re350k-v1|\
        tplink,re355-v1|\
index 5229ad17f4e477448672b20cf3aebd0812a4fe4d..5be1c72ab0ab67a63b7df38bbe0a93bfb12102ba 100644 (file)
@@ -208,6 +208,7 @@ case "$FIRMWARE" in
                ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
                        /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
                ;;
                ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
                        /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
                ;;
+       tplink,eap225-outdoor-v1|\
        tplink,eap225-wall-v2|\
        tplink,tl-wpa8630p-v2-int|\
        tplink,tl-wpa8630p-v2.0-eu|\
        tplink,eap225-wall-v2|\
        tplink,tl-wpa8630p-v2-int|\
        tplink,tl-wpa8630p-v2.0-eu|\
index c704d99c98e04f18f28f7c0cad0c41d89e26c4ed..343ea963c372e6d08bb9f9b763cfc1f0489822dc 100644 (file)
@@ -371,6 +371,17 @@ define Device/tplink-eap2x5
        pad-extra 128
 endef
 
        pad-extra 128
 endef
 
+define Device/tplink_eap225-outdoor-v1
+  $(Device/tplink-eap2x5)
+  SOC := qca9563
+  IMAGE_SIZE := 13824k
+  DEVICE_MODEL := EAP225-Outdoor
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  TPLINK_BOARD_ID := EAP225-OUTDOOR-V1
+endef
+TARGET_DEVICES += tplink_eap225-outdoor-v1
+
 define Device/tplink_eap225-wall-v2
   $(Device/tplink-eap2x5)
   SOC := qca9561
 define Device/tplink_eap225-wall-v2
   $(Device/tplink-eap2x5)
   SOC := qca9561
index 2657b2c928e6a3298047a0b56068c2409f7ffe05..4389cf03462284a029dd0dc4c616bf5615af2c49 100644 (file)
@@ -1298,6 +1298,35 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "file-system"
        },
 
                .last_sysupgrade_partition = "file-system"
        },
 
+       /** Firmware layout for the EAP225-Outdoor v1 */
+       {
+               .id     = "EAP225-OUTDOOR-V1",
+               .support_list =
+                       "SupportList:\r\n"
+                       "EAP225-Outdoor(TP-Link|UN|AC1200-D):1.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+               .soft_ver_compat_level = 1,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x02000},
+                       {"default-mac", 0x30000, 0x01000},
+                       {"support-list", 0x31000, 0x00100},
+                       {"product-info", 0x31100, 0x00400},
+                       {"soft-version", 0x32000, 0x00100},
+                       {"firmware", 0x40000, 0xd80000},
+                       {"user-config", 0xdc0000, 0x30000},
+                       {"mutil-log", 0xf30000, 0x80000},
+                       {"oops", 0xfb0000, 0x40000},
+                       {"radio", 0xff0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system"
+       },
+
        /** Firmware layout for the EAP225-Wall v2 */
        {
                .id     = "EAP225-WALL-V2",
        /** Firmware layout for the EAP225-Wall v2 */
        {
                .id     = "EAP225-WALL-V2",