ath79: add support for Qxwlan E1700AC v2
author张鹏 <sd20@qxwlan.com>
Fri, 16 Oct 2020 10:53:51 +0000 (12:53 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 17 Oct 2020 18:18:00 +0000 (20:18 +0200)
E1700AC v2 based on Qualcomm/Atheros QCA9563 + QCA9880.

Specification:

 - 750/400/250 MHz (CPU/DDR/AHB)
 - 128 MB of RAM (DDR2)
 - 8/16 MB of FLASH (SPI NOR)
 - 3T3R 2.4 GHz
 - 3T3R 5 GHz
 - 2 x 10/1000M Mbps Ethernet (RJ45)
 - 1 x MiniPCI-e
 - 1 x SIM (3G/4G)
 - 1 x USB 2.0 Port
 - 5 x LED , 2 x Button(S8-Reset Buttun), 1 x power input
 - UART (J5) header on PCB (115200 8N1)

Flash instruction:

   1.Using tftp mode with UART connection and original LEDE image
      - Configure PC with static IP 192.168.1.10 and tftp server.
      - Rename "openwrt-ar71xx-generic-xxx-squashfs-sysupgrade.bin"
        to "firmware.bin" and place it in tftp server directory.
      - Connect PC with one of LAN ports, power up the router and press
        key "Enter" to access U-Boot CLI.
      - Use the following commands to update the device to LEDE:
        run lfw
      - After that the device will reboot and boot to LEDE.
      - Wait until all LEDs stops flashing and use the router.

   2.Using httpd mode with Web UI connection and original LEDE image
      - Configure PC with static IP 192.168.1.xxx(2-255) and tftp server.
      - Connect PC with one of LAN ports,press the reset button, power up
        the router and keep button pressed for around 6-7 seconds, until
        leds flashing.
      - Open your browser and enter 192.168.1.1,You will see the upgrade
        interface, select "openwrt-ar71xx-generic-xxx-squashfs-
        sysupgrade.bin" and click the upgrade button.
      - After that the device will reboot and boot to LEDE.
      - Wait until all LEDs stops flashing and use the router.

Signed-off-by: 张鹏 <sd20@qxwlan.com>
[cut out of bigger patch, keep swconfig, whitespace fixes]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/qca9563_qxwlan_e1700ac-v2-16m.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9563_qxwlan_e1700ac-v2-8m.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9563_qxwlan_e1700ac.dtsi [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9563_qxwlan_e1700ac-v2-16m.dts b/target/linux/ath79/dts/qca9563_qxwlan_e1700ac-v2-16m.dts
new file mode 100644 (file)
index 0000000..b851380
--- /dev/null
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9563_qxwlan_e1700ac.dtsi"
+
+/ {
+       model = "Qxwlan E1700AC v2 16M";
+       compatible = "qxwlan,e1700ac-v2-16m", "qca,qca9563";
+};
+
+&partitions {
+       partition@70000 {
+               compatible = "denx,uimage";
+               label = "firmware";
+               reg = <0x070000 0xf90000>;
+       };
+};
diff --git a/target/linux/ath79/dts/qca9563_qxwlan_e1700ac-v2-8m.dts b/target/linux/ath79/dts/qca9563_qxwlan_e1700ac-v2-8m.dts
new file mode 100644 (file)
index 0000000..7aaac48
--- /dev/null
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9563_qxwlan_e1700ac.dtsi"
+
+/ {
+       model = "Qxwlan E1700AC v2 8M";
+       compatible = "qxwlan,e1700ac-v2-8m", "qca,qca9563";
+};
+
+&partitions {
+       partition@70000 {
+               compatible = "denx,uimage";
+               label = "firmware";
+               reg = <0x070000 0x790000>;
+       };
+};
diff --git a/target/linux/ath79/dts/qca9563_qxwlan_e1700ac.dtsi b/target/linux/ath79/dts/qca9563_qxwlan_e1700ac.dtsi
new file mode 100644 (file)
index 0000000..0c397e7
--- /dev/null
@@ -0,0 +1,157 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca956x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               label-mac-device = &eth0;
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "green:system";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               usb {
+                       label = "green:usb";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       trigger-sources = <&hub_port0>;
+                       linux,default-trigger = "usbport";
+               };
+
+               wlan2g {
+                       label = "green:wlan2g";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       pridata: partition@50000 {
+                               label = "pri-data";
+                               reg = <0x050000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@60000 {
+                               label = "art";
+                               reg = <0x060000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+               qca,mib-poll-interval = <500>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+               >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0x03000101 0x00000101 0x00001919>;
+
+       phy-mode = "sgmii";
+       phy-handle = <&phy0>;
+
+       mtd-mac-address = <&pridata 0x400>;
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&usb0 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy1 {
+       status = "okay";
+};
+
+&usb1 {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index 8f528c33cdf49d4f1dcd497849c12fba192017b6..a587cfac96883b15b1e2a8254e68787d24372e77 100755 (executable)
@@ -244,6 +244,8 @@ ath79_setup_interfaces()
                        "0@eth0" "2:lan:1" "3:lan:2" "4:lan:3" "5:lan:4" "1:wan"
                ;;
        nec,wg1200cr|\
+       qxwlan,e1700ac-v2-8m|\
+       qxwlan,e1700ac-v2-16m|\
        qxwlan,e750g-v8-8m|\
        qxwlan,e750g-v8-16m|\
        ubnt,nanostation-ac|\
index 857f566db8d3e1c1f15f8f30048971e5f637c7d8..25e864ba72bb1155eb6e828b044e5075e707fd6e 100644 (file)
@@ -22,6 +22,8 @@ case "$FIRMWARE" in
        comfast,cf-wr650ac-v1|\
        comfast,cf-wr650ac-v2|\
        devolo,magic-2-wifi|\
+       qxwlan,e1700ac-v2-8m|\
+       qxwlan,e1700ac-v2-16m|\
        ubnt,unifiac-lite|\
        ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
index 528a63f629d808c3685fa6985acb71ae2c6745a8..8b0c2478760cae6a807e02893defb61b41c6fe5e 100644 (file)
@@ -1475,6 +1475,27 @@ define Device/qihoo_c301
 endef
 TARGET_DEVICES += qihoo_c301
 
+define Device/qxwlan_e1700ac-v2
+  SOC := qca9563
+  DEVICE_VENDOR := Qxwlan
+  DEVICE_MODEL := E1700AC
+  DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+
+define Device/qxwlan_e1700ac-v2-16m
+  $(Device/qxwlan_e1700ac-v2)
+  DEVICE_VARIANT := v2 (16M)
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e1700ac-v2-16m
+
+define Device/qxwlan_e1700ac-v2-8m
+  $(Device/qxwlan_e1700ac-v2)
+  DEVICE_VARIANT := v2 (8M)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e1700ac-v2-8m
+
 define Device/qxwlan_e558-v2
   SOC := qca9558
   DEVICE_VENDOR := Qxwlan