mediatek: mt7623: allow build without ext4 rootfs
authorDaniel Golle <daniel@makrotopia.org>
Wed, 21 Jul 2021 14:32:00 +0000 (15:32 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 21 Jul 2021 14:34:21 +0000 (15:34 +0100)
The image generation code for the U7623 board expects ext4 filesystem
to be selected in menuconfig and CONFIG_TARGET_ROOTFS_PARTSIZE to be
defined. Now that ext4 isn't enabled any more, the variable was missing
and broke the build.
Set the default (104) instead of using the config variable to fix that.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/mt7623.mk

index 00c1ac4443e2b9e723ae2cfd38ae5f4bffcdf5b9..653da6b2c08d2da33d33366cf4d419e7f107c23b 100644 (file)
@@ -132,7 +132,7 @@ define Build/mtk-mmc-img
                $@.boot \
                $(IMAGE_ROOTFS) \
                $(CONFIG_MTK_BOOT_PARTSIZE) \
-               $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+               104
 endef
 
 define Build/scatterfile