kernel: limit crypto-hw-ccp to the x86
authorRafał Miłecki <rafal@milecki.pl>
Tue, 13 Apr 2021 08:15:39 +0000 (10:15 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Wed, 14 Apr 2021 06:42:38 +0000 (08:42 +0200)
CRYPTO_DEV_CCP depends on X86 or ARM64
CRYPTO_DEV_CCP_DD depends on CPU_SUP_AMD or ARM64

Compiling this driver makes sense for x86 mainly. If one day support for
ARM64 board with AMD Secure Processor gets added this package may be
updated.

Trying to build this package on bcm4908 was causing:
ERROR: module 'build_dir/target-aarch64_cortex-a53_musl/linux-bcm4908_generic/linux-5.4.110/drivers/crypto/ccp/ccp-crypto.ko' is missing.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit cb3fb45ed1262355e8c31d8e522f411169ee6df8)

package/kernel/linux/modules/crypto.mk

index b8b9e5f9fd716af96df87fb2d1559bf64f879c5a..b50ed06824bc7a57e70f98d3621729f034d5f3fc 100644 (file)
@@ -314,6 +314,7 @@ $(eval $(call KernelPackage,crypto-hmac))
 define KernelPackage/crypto-hw-ccp
   TITLE:=AMD Cryptographic Coprocessor
   DEPENDS:= \
+       @TARGET_x86 \
        +kmod-crypto-authenc \
        +kmod-crypto-hash \
        +kmod-crypto-manager \