ucode: update to latest Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Wed, 21 Sep 2022 21:33:56 +0000 (23:33 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 14 Oct 2022 22:39:48 +0000 (00:39 +0200)
4ae7072 fs: use `getline()` for line wise read operations
21ace5e lexer: fixes for regex literal parsing
00965fa lib: implement slice() function
76d396d main: implement print mode
7bbba78 compiler: optimize function return opcode generation
a45f2a3 lexer: improve regex literal handling
d64d5d6 vm: maintain export symbol tables per program
f4b4ded uloop: task: gracefully handle absent output callback
a58fe47 ubus: hold reference to underlying connection until deferred is concluded
e23b58a lib: uc_system(): retry waitpid() on EINTR

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile

index 185133c554a3bfa064437f5d93f1993a1d3dad2b..54127582bd6a79bd1b6f0f4b17153e7d5dc2e896 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2022-09-09
-PKG_SOURCE_VERSION:=7fa59ce44b9347528b0e4e44ebcfb04a08479f3f
-PKG_MIRROR_HASH:=abef8939104db9d08d18fc65941d9357b8fc1b0f3b511e361388789972d0a44b
+PKG_SOURCE_DATE:=2022-10-07
+PKG_SOURCE_VERSION:=4ae70721aae5f974538928cadc71fa3269e5ad20
+PKG_MIRROR_HASH:=97339d563e988d57ed02f5fd27722c908d616c2cec8b1f0479f42bc53dfd0aa1
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC