ramips: mt7621: use lzma-loader for ra21s & rg21s
authorFurkan Alaca <furkan.alaca@queensu.ca>
Fri, 3 Jul 2020 05:51:03 +0000 (01:51 -0400)
committerPetr Štetiar <ynezz@true.cz>
Wed, 8 Jul 2020 20:52:40 +0000 (22:52 +0200)
The rg21s fails to boot if the kernel is larger than about
2,376 KiB. The ra21s is virtually identical hardware.
Enabling lzma-loader resolves the issue on both the rg21s
and ra21s (see FS#3057 on the issue tracker).

Fixes: FS#3057
Signed-off-by: Furkan Alaca <furkan.alaca@queensu.ca>
target/linux/ramips/image/mt7621.mk

index 5e67d46ade841de0412fe45167406a9fbd7a0c9d..0215683671b257c7d8357d6447e32d77c8537f3e 100644 (file)
@@ -262,6 +262,7 @@ endef
 TARGET_DEVICES += d-team_pbr-m1
 
 define Device/edimax_ra21s
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := RA21S
@@ -293,6 +294,7 @@ endef
 TARGET_DEVICES += edimax_re23s
 
 define Device/edimax_rg21s
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := Gemini AC2600 RG21S