thc-ipv6: update to 3.8
authorNick Hainke <vincent@systemli.org>
Mon, 26 Sep 2022 05:22:08 +0000 (07:22 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Oct 2022 19:10:34 +0000 (21:10 +0200)
Remove upstreamed patches:
- 000-cflags_override.patch

Manually refresh patches:
- 100-no-ssl.patch

Add patches:
- 101-remove-march-native.patch

Add THC_APPLETS:
- toobigsniff6
- flood_unreach6
- connect6

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/ipv6/thc-ipv6/Makefile
package/network/ipv6/thc-ipv6/patches/000-cflags_override.patch [deleted file]
package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch
package/network/ipv6/thc-ipv6/patches/101-remove-march-native.patch [new file with mode: 0644]

index 91bacf625e3a49a9b3d8aad5717c9309cc82fe57..b26b0507fb784b09c908ff415fcfa66c191ec25e 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=thc-ipv6
-PKG_VERSION:=2.7
+PKG_VERSION:=3.8
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GITHUB/vanhauser-thc/THC-Archive/master/Tools
-PKG_HASH:=440a3ae98b57100c397ec4f8634468dbbb0c3b48788c6b74af2a597a90544a96
+PKG_HASH:=b60be61a8b0a944a66e3b719704b4c03c1bc2c22f32d5d21e99e434c82a9d769
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
@@ -31,7 +31,7 @@ THC_APPLETS := \
        fuzz_dhcps6 implementation6 implementation6d inverse_lookup6          \
        kill_router6 ndpexhaust6 node_query6 parasite6 passive_discovery6     \
        randicmp6 redir6 rsmurf6 sendpees6 sendpeesmp6 smurf6 thcping6        \
-       toobig6 trace6
+       toobig6 trace6 toobigsniff6 flood_unreach6 connect6
 
 THC_DEPENDS_dnsdict6 := +libpthread
 THC_DEPENDS_thcping6 := +librt
diff --git a/package/network/ipv6/thc-ipv6/patches/000-cflags_override.patch b/package/network/ipv6/thc-ipv6/patches/000-cflags_override.patch
deleted file mode 100644 (file)
index e1c36b6..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN thc-ipv6-2.7/Makefile thc-ipv6-2.7.new/Makefile
---- thc-ipv6-2.7/Makefile      2014-12-27 05:05:30.000000000 -0800
-+++ thc-ipv6-2.7.new/Makefile  2017-02-04 20:55:51.679898101 -0800
-@@ -3,7 +3,7 @@
- CC=gcc
- #CFLAGS=-g
--CFLAGS=-O2
-+CFLAGS?=-O2
- CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
- LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
- PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6 thcsyn6 redirsniff6 flood_redir6 four2six dump_dhcp6 fuzz_dhcps6 flood_rs6 fuzz_dhcpc6
index 1ef1f66be88bd77ee65502417028760248933183..118c2a705bc958d12efbe1b931906e92b427fa59 100644 (file)
@@ -1,9 +1,10 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -1,5 +1,5 @@
+@@ -1,6 +1,6 @@
  # Comment out if openssl-dev is not present
+ # of if you want to compile statc
 -HAVE_SSL=yes
 +#HAVE_SSL=yes
  
- CC=gcc
- #CFLAGS=-g
+ # comment in if you want to compile static tools
+ #STATIC=-static
diff --git a/package/network/ipv6/thc-ipv6/patches/101-remove-march-native.patch b/package/network/ipv6/thc-ipv6/patches/101-remove-march-native.patch
new file mode 100644 (file)
index 0000000..da6c7ca
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -7,7 +7,7 @@ HAVE_SSL=yes
+ #CC=gcc
+ #CFLAGS=-g
+-CFLAGS+=-g -O3 -march=native -flto -falign-functions -falign-jumps -falign-loops -falign-labels -freorder-blocks
++CFLAGS+=-g -O3 -flto -falign-functions -falign-jumps -falign-loops -falign-labels -freorder-blocks
+ CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
+ LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
+ PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6 thcsyn6 redirsniff6 flood_redir6 four2six dump_dhcp6 flood_rs6 fuzz_dhcps6 fuzz_dhcpc6 toobigsniff6 flood_unreach6 connect6