fix unnecessary rebuilds for library package directories with no selected packages
authorFelix Fietkau <nbd@openwrt.org>
Thu, 7 Sep 2006 12:14:08 +0000 (12:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 7 Sep 2006 12:14:08 +0000 (12:14 +0000)
SVN-Revision: 4767

openwrt/include/package.mk

index 9a947f358248338773337f374e0d996ba8a45b8e..515698d691d3b7064617aa168cd9bba00aa7b7f8 100644 (file)
@@ -17,20 +17,10 @@ define Build/DefaultTargets
     ifeq ($(CONFIG_AUTOREBUILD),y)
       _INFO:=
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
     ifeq ($(CONFIG_AUTOREBUILD),y)
       _INFO:=
       ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
-       _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
+        _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
 
-      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-        _INFO+=$(subst $(TOPDIR)/,,$(IPKG_$(1)))
-        $(PKG_BUILD_DIR)/.built: package-rebuild
-      endif
-
-      ifneq ($(MAKECMDGOALS),prereq)
-        ifneq ($$(_INFO),)
-          $$(info Rebuilding $$(_INFO))
-        endif
-      endif
     endif
   endif
 
     endif
   endif
 
@@ -241,6 +231,19 @@ define BuildPackage
        @touch $$@
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
        @touch $$@
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
+
+  ifneq ($$(CONFIG_PACKAGE_$(1)),)
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$$(IPKG_$(1)))
+      _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+      $(PKG_BUILD_DIR)/.built: package-rebuild
+    endif
+
+    ifneq ($(MAKECMDGOALS),prereq)
+      ifneq ($$(_INFO),)
+        $$(info Rebuilding $$(_INFO))
+      endif
+    endif
+  endif
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
 endef
 
 ifneq ($(strip $(PKG_CAT)),)