kernel: fix missing dependency in 4.14.108
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 27 Mar 2019 15:46:39 +0000 (16:46 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 27 Mar 2019 15:46:39 +0000 (16:46 +0100)
The 4.14.108 bump introduced a missing dependency when building
specific netfilters.

Thsi was not seen as the error does not occur on all targets.

Thanks to Jo-Philipp Wich for providing the fix

Fixes: af6c86dbe56e ("kernel: bump 4.14 to 4.14.108")
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
package/kernel/linux/modules/netfilter.mk

index 6c78394297be189fea9f1215f71aad92584bdbef..dc3cdb6531e0a780243d896623f9ed87343951a8 100644 (file)
@@ -368,7 +368,7 @@ IPVS_MODULES:= \
 define KernelPackage/nf-ipvs
   SUBMENU:=Netfilter Extensions
   TITLE:=IP Virtual Server modules
-  DEPENDS:=@IPV6 +kmod-lib-crc32c +kmod-ipt-conntrack +kmod-nf-conntrack
+  DEPENDS:=@IPV6 +kmod-lib-crc32c +kmod-ipt-conntrack +kmod-nf-conntrack +LINUX_4_14:kmod-nf-conntrack6
   KCONFIG:= \
        CONFIG_IP_VS \
        CONFIG_IP_VS_IPV6=y \