brcm63xx: Add DT support for 96368MVWG
authorJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:26:07 +0000 (12:26 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:26:07 +0000 (12:26 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42738

33 files changed:
target/linux/brcm63xx/dts/bcm96368MVWG.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/01-generic.mk

diff --git a/target/linux/brcm63xx/dts/bcm96368MVWG.dts b/target/linux/brcm63xx/dts/bcm96368MVWG.dts
new file mode 100644 (file)
index 0000000..f462411
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6368.dtsi"
+
+/ {
+       model = "Broadcom BCM96368MVWG reference board";
+       compatible = "brcm,bcm96368mvwg", "brcm,bcm6368";
+};
index 63528ddcb2005f63eb9d1bf5a8e4d9d264cca2ac..b7789cf368bd7b80af097da0523429ae62e2fbb6 100755 (executable)
@@ -233,8 +233,6 @@ endef
 
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
-       # Various routers
-       $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
 
        # BT Voyager V210_BTR
        $(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
 
        # BT Voyager V210_BTR
        $(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
@@ -351,6 +349,8 @@ $(eval $(call CfeImageDTB,96358VW,bcm96358VW,96358VW,6358,96358VW-generic))
 $(eval $(call CfeImageDTB,96358VW2,bcm96358VW2,96358VW2,6358,96358VW2-generic))
 # Generic 96368MVNgr
 $(eval $(call CfeImageDTB,96368MVNgr,bcm96368MVNgr,96368MVNgr,6368,96368MVNgr-generic))
 $(eval $(call CfeImageDTB,96358VW2,bcm96358VW2,96358VW2,6358,96358VW2-generic))
 # Generic 96368MVNgr
 $(eval $(call CfeImageDTB,96368MVNgr,bcm96368MVNgr,96368MVNgr,6368,96368MVNgr-generic))
+# Generic 96368MVWG
+$(eval $(call CfeImageDTB,96368MVWG,bcm96368MVWG,96368MVWG,6368,96368MVWG-generic))
 
 # ADB P.DG A4001N
 $(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
 
 # ADB P.DG A4001N
 $(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
index c320f77c7b65c8ce164c2c02d3f522faa2f643de..2256bd86b7bec934f34076a9e42f8c6bdc5c0b54 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1936,6 +1936,85 @@ static struct board_info __initdata boar
+@@ -1936,6 +1936,86 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
@@ -19,6 +19,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 +#ifdef CONFIG_BCM63XX_CPU_6368
 +static struct board_info __initdata board_96368mvwg = {
 +      .name                           = "96368MVWG",
 +#ifdef CONFIG_BCM63XX_CPU_6368
 +static struct board_info __initdata board_96368mvwg = {
 +      .name                           = "96368MVWG",
++      .of_board_id                    = "brcm,bcm96368mvwg",
 +      .expected_cpu_id                = 0x6368,
 +
 +      .has_uart0                      = 1,
 +      .expected_cpu_id                = 0x6368,
 +
 +      .has_uart0                      = 1,
@@ -96,7 +97,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -1987,6 +2066,10 @@ static const struct board_info __initcon
+@@ -1987,6 +2067,10 @@ static const struct board_info __initcon
        &board_HW553,
        &board_spw303v,
  #endif
        &board_HW553,
        &board_spw303v,
  #endif
index 720ea6d1ade4d45042573409194004dbebd38ca5..ccd24cabb5206144d312bc061e3e5a71556f9c14 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2012,6 +2012,73 @@ static struct board_info __initdata boar
+@@ -2013,6 +2013,73 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
@@ -83,7 +83,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2069,6 +2136,7 @@ static const struct board_info __initcon
+@@ -2070,6 +2137,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
index ec7b95bbe268b4e061c7c3342a4aae0cedaca807..e0ad162765ccf9a6eae8edc541142b56dd8f4ffe 100644 (file)
@@ -87,7 +87,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2122,6 +2193,7 @@ static const struct board_info __initcon
+@@ -2123,6 +2194,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index e14663d24da39556e33b8292737597f1e7985dac..67f42dfc100d492b4c0a733d27e03b124b7b4eba 100644 (file)
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2194,6 +2299,7 @@ static const struct board_info __initcon
+@@ -2195,6 +2300,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 0ed9f532f2c3333294bf91391b2b236281b76b4b..911dcc5f72fa8da4e4029db6936e9839a0031864 100644 (file)
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
-@@ -2329,6 +2382,7 @@ static const struct board_info __initcon
+@@ -2330,6 +2383,7 @@ static const struct board_info __initcon
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
index 00b00aa4641fa861b3ad831267395210a9506ca4..5659af123742a705892343242f94ca605029afb8 100644 (file)
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
-@@ -2394,6 +2519,7 @@ static const struct board_info __initcon
+@@ -2395,6 +2520,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index a71be36ecf056370aedfcceef320b9a51de99849..685bd16ed8d605c6256508f973ea39ba6fed71d7 100644 (file)
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2522,6 +2590,7 @@ static const struct board_info __initcon
+@@ -2523,6 +2591,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 26ad63c1fcde0be9ddf23d3fdec0b8e7ff76eb83..28a62f62d3a776ef12386e4d9b2d5049a44174d4 100644 (file)
  /*
   * known 6368 boards
   */
  /*
   * known 6368 boards
   */
-@@ -2593,6 +2695,10 @@ static const struct board_info __initcon
+@@ -2594,6 +2696,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
        &board_DVAG3810BN,
  #endif
  
index 55a01c9101d5e4864b691f00e812407258e1bfa5..34bf6b5fea6129084f111573a5bc63f18e835b0d 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2666,6 +2717,7 @@ static const struct board_info __initcon
+@@ -2667,6 +2718,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index f56b677c7491073e211f7b08f57ffccf7460d9ad..881319bb27c68823de8fa7f69cd398f59d73ceae 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2698,6 +2826,7 @@ static const struct board_info __initcon
+@@ -2699,6 +2827,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 07af3cc0e1bf70644674c3071fa03d70e9bb8ac2..851337ac85ebf7d74bfc956308585353cfcca1eb 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .of_board_id                    = "brcm,bcm963281TAN",
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .of_board_id                    = "brcm,bcm963281TAN",
-@@ -2825,6 +2935,7 @@ static const struct board_info __initcon
+@@ -2826,6 +2936,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 134114ec4bef6d14e656ec472e3ea2e9dc2e1dda..bc8ef76c9a2419dd5e84d8da9d779b72b8d76e92 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2935,6 +3021,7 @@ static const struct board_info __initcon
+@@ -2936,6 +3022,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 504598e783afb9a8f1cf9c35c951bd1b6db559a9..d9dddc65db4a6fbf3f0a3de84dcd479c6b931436 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3035,6 +3084,7 @@ static const struct board_info __initcon
+@@ -3036,6 +3085,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index aefe4074d29a037ca44d59a5065bbd92a5803a27..216e5a443c3d0ef8b07fe63d39dca69e46117126 100644 (file)
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3120,6 +3520,9 @@ static const struct board_info __initcon
+@@ -3121,6 +3521,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index a66a53606a2c934299ee9f1a9fed702c121f6a43..ef8c8f47ca9a431b94f61441999fc95aa3ac679e 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3485,6 +3539,7 @@ static const struct board_info __initcon
+@@ -3486,6 +3540,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index e8fba3176a7da9a04c6556ba962ab264ae335cad..486d87a13cd011e8079b028dd28a462d3b8ff9a5 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3529,6 +3645,7 @@ static const struct board_info __initcon
+@@ -3530,6 +3646,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index cb65d697cc911cb80c454f3f0e301f142798165f..ca9047f7bc5033c135209cb968240deda753efc2 100644 (file)
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3701,6 +3791,7 @@ static const struct board_info __initcon
+@@ -3702,6 +3792,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index dc904eb3fee035d8b72f98256b42424e8278fe38..4bdd841883bdbd03a1014f093aa4491439d1f70e 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3959,6 +4046,9 @@ static const struct board_info __initcon
+@@ -3960,6 +4047,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 6bb1a63a8ddd21bbb6b5b6f41b2c3f116f0cbf93..6905295718ecfa5984d5bb649ecd749b41e92e23 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4048,6 +4136,7 @@ static const struct board_info __initcon
+@@ -4049,6 +4137,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 7691f11d2c832debe7877f905f78200b7598d92c..663fe6e4bd441d6ce6d1b6f1b3080225c2067c8d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4128,6 +4128,75 @@ static struct board_info __initdata boar
+@@ -4129,6 +4129,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4208,6 +4277,9 @@ static const struct board_info __initcon
+@@ -4209,6 +4278,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 21feb6dc69e8d8c9b2f68fe1591ebbd6cabbf949..9881b19b83e4e64e27092e82ad5af89ff591a902 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4248,6 +4294,7 @@ static const struct board_info __initcon
+@@ -4249,6 +4295,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 1038b07192d8392a33ae9333c08f9921efa36d7a..518556385a574d56b93aa9682b33889ee4ed0a11 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4240,6 +4240,108 @@ static struct board_info __initdata boar
+@@ -4241,6 +4241,108 @@ static struct board_info __initdata boar
                },
        },
  };
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4326,6 +4428,7 @@ static const struct board_info __initcon
+@@ -4327,6 +4429,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index b4e1c4997e27566a4f1e3bc7a814921842acc9d0..ef0fe51c662b711e94a4b2a5ec5a57ce3b039263 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4177,6 +4177,131 @@ static struct board_info __initdata boar
+@@ -4178,6 +4178,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4427,6 +4552,7 @@ static const struct board_info __initcon
+@@ -4428,6 +4553,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 8566595049013a557f6001c135566bc857d353d3..22ab61b2a712abacfd710818f342930bf6fef9d0 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4171,6 +4172,118 @@ static struct board_info __initdata boar
+@@ -4172,6 +4173,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4550,6 +4663,7 @@ static const struct board_info __initcon
+@@ -4551,6 +4664,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index ce5a2d122f383e2d18eee8b2252405bbf52323e6..05f55edaa96da8be23fd753a54412569b98ab75b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4173,6 +4173,117 @@ static struct board_info __initdata boar
+@@ -4174,6 +4174,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4663,6 +4774,7 @@ static const struct board_info __initcon
+@@ -4664,6 +4775,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index c985bb61af339934885d6a7803c51b6de3adb143..09ba60390cf45be8508b093020521669a101b50a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4284,6 +4284,117 @@ static struct board_info __initdata boar
+@@ -4285,6 +4285,117 @@ static struct board_info __initdata boar
        },
  };
  
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4775,6 +4886,7 @@ static const struct board_info __initcon
+@@ -4776,6 +4887,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index f219e42b93384b24577e1201a8158a8b7e79462c..a9cde2f0e8f8ad2e3a740a6a4ab4a3300b66130a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4182,6 +4182,97 @@ static struct sprom_fixup __initdata vr3
+@@ -4183,6 +4183,97 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -98,7 +98,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4885,6 +4976,7 @@ static const struct board_info __initcon
+@@ -4886,6 +4977,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index ebdd899b6b44aaa367926c8e59664bbddf68e86e..245f5948095682e2e701d386cd0ba0b3465e2094 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
-@@ -4960,6 +5011,7 @@ static const struct board_info __initcon
+@@ -4961,6 +5012,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index de4fd11275f84d08faae86868c9956b37149748d..454e5cfe0049d415cb30cfbfe819898f4e36b459 100644 (file)
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .of_board_id                    = "adb,a4001n1",
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .of_board_id                    = "adb,a4001n1",
-@@ -4962,6 +5052,7 @@ static const struct board_info __initcon
+@@ -4963,6 +5053,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 7c7abeb51b9e155612c5d9f240877f8bccab99be..7a209591562cedb3b2931dc1cc76ada2c13602af 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5046,6 +5181,7 @@ static const struct board_info __initcon
+@@ -5047,6 +5182,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index f190141a4123c5e42feb0b88accad15ce3127dc0..2a9eb15e00e87bfbdf5c3693078efe51b9ce1742 100644 (file)
@@ -112,3 +112,12 @@ define Profile/96368MVNgr/Description
   Package set optimized for 96368MVNgr.
 endef
 $(eval $(call Profile,96368MVNgr))
   Package set optimized for 96368MVNgr.
 endef
 $(eval $(call Profile,96368MVNgr))
+
+define Profile/96368MVWG
+  NAME:=Generic 96368MVWG
+  PACKAGES:=
+endef
+define Profile/96368MVWG/Description
+  Package set optimized for 96368MVWG.
+endef
+$(eval $(call Profile,96368MVWG))