fix libtool version checks in some configure scripts
authorFelix Fietkau <nbd@openwrt.org>
Thu, 27 Dec 2007 02:11:11 +0000 (02:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 27 Dec 2007 02:11:11 +0000 (02:11 +0000)
SVN-Revision: 9943

include/autotools.mk

index fd57e6472747af8cd1bf65b4cbf36e61552f0794..24503182514313ef4a4694a6556057294251f193 100644 (file)
@@ -14,17 +14,25 @@ define replace
 endef
 
 # replace copies of ltmain.sh with the build system's version
 endef
 
 # replace copies of ltmain.sh with the build system's version
-update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)
+update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
 
 # prevent libtool from linking against host development libraries
 define libtool_fixup_libdir
        find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
 
 # prevent libtool from linking against host development libraries
 define libtool_fixup_libdir
        find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
-               $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
+               $(SED) "s,^libdir='/usr/lib',libdir='$(if $(PKG_INSTALL_DIR),$(PKG_INSTALL_DIR),$(STAGING_DIR))/usr/lib',g"
+endef
+
+define remove_version_check
+       if [ -f "$(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure" ]; then \
+               $(SED) \
+                       's,pardus_ltmain_version=.*,pardus_ltmain_version="$$$$pardus_lt_version",' \
+                       $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure; \
+       fi
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool
+  Hooks/Configure/Pre += update_libtool remove_version_check
   Hooks/Configure/Post += update_libtool
   Hooks/Configure/Post += update_libtool
-  Hooks/Build/Post += libtool_fixup_libdir
+  Hooks/Compile/Post += libtool_fixup_libdir
 endif
 endif