build: revert "make image target wait for initramfs"
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 15 Mar 2018 20:51:19 +0000 (21:51 +0100)
committerMathias Kresin <dev@kresin.me>
Thu, 15 Mar 2018 21:27:37 +0000 (22:27 +0100)
This reverts commit 43be5087a915727e7dcb3459e2221f094c70811b.

The change is incompatible with the image builder code.
Luckily the RT-AC58U is no longer depending on the initramfs
being available for the target's image generation rules.

Reported-by: Venitex Aveon <aveon@aenote.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
include/image.mk

index 64c224e55fc26ed3bc62ec665f95493b67bbd13c..771f5b2c76e2cd176acc5d7f8d9672650795a253 100644 (file)
@@ -480,7 +480,7 @@ define Device/Build/image
   ifndef IB
     $$(ROOTFS/$(1)/$(3)): $(if $(TARGET_PER_DEVICE_ROOTFS),target-dir-$$(ROOTFS_ID/$(3)))
   endif
-  $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $$(KDIR_KERNEL_IMAGE) $$(ROOTFS/$(1)/$(3)) $$(if $$(CONFIG_TARGET_ROOTFS_INITRAMFS),$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE))
+  $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $$(KDIR_KERNEL_IMAGE) $$(ROOTFS/$(1)/$(3))
        @rm -f $$@
        [ -f $$(word 1,$$^) -a -f $$(word 2,$$^) ]
        $$(call concat_cmd,$(if $(IMAGE/$(2)/$(1)),$(IMAGE/$(2)/$(1)),$(IMAGE/$(2))))